Условие в запросе 1с как допреквизит
Перейти к содержимому

Условие в запросе 1с как допреквизит

  • автор:

Условие в запросе 1с как допреквизит

Здравствуйте. Беру данные из регистра накопления, там есть номенклатура, у нее есть доп реквизиты, типа автор и класс, они хранятся в табличной части доп реквизиты и эти доп реквизиты сделаны через план видов характеристик. Как мне получить этот доп реквизит и вывести его значение в отчете сразу скд, чтобы было настроить эти поля.

Связь со справочником номенклатуры, и из тч вытягивай доп реквизит
Вкладка «Характеристики»

настроить где? в отборе? берешь раскрываешь номенклатуру в выбранных полях слева нажав на плюс, там будут твои поля. в чем вопрос то?

(3) это в предприятии будет, а в конфигарутор его нет, а я хочу в скд в конфигаруторе вытащить эти поля, чтобы потом пользователь не вытаскитвал.
(2) через вкладку характеристику, как в УТ 11, когда доп реквизит это тч этой номенклатуры.
(1) вроде как из тч можно но это нагрузка на время запроса

(4) вытащи их в предприятии и сохрани вариант отчета для пользователя.
как ты не поймешь, ты можешь ввести в предприятии все что хочешь в эту ТЧ, откуда конфигуратор узнает что ты там навводил? используй штатные средства (варианты отчета)

(0) Это делается немножко криво
Сначала создаешь таблицу значений, в которую програмно добавляешь требуемые реквизиты (Автор и класс) . Их тип соответственно ПланХарактеристик
Передаешь тз в запрос
В запросе выбираешь из ТЧ ДопРеквизиты, соединяя их с переданной ТЗ и одновременно ограничивая их переданной ТЗ.

Или второй вариант — передаешь в запрос два параметра, полученных програмно (Автор и Класс), соединяешь с ТЧ дважды. Один раз ограничиваешь ТЧ Автором, второй раз Классом. ТОгда сможешь реквизиты вытащить как бы в шапку.

(6) Нахрена такие танцы
Просто в запросе добавляешь левое соединение с таб частью Доп. реквизиты по объекту и свойство = &ПараметрСвойство.
Потом еще одно левое соединение с другим свойством.
ПараметрСвойство устанавливаешь в ПриКомпоновкеРезультата.

(7) только вначале ТЧ лучше поместить во временную таблицу
(7) при какой еще компоновке? допреквизиты долступны ШТАТНО через предприятие
немного матчасти для тех, кто в танке http://v8.1c.ru/overview/Term_000000276.htm

(7) Во первых Я так и написал во втором варианте.
Во вторых, кроме ТЧ доп реквизитов стоит задача не выбрать «ВСЕ» реквизиты, а только те, у которых название Автор и класс. Поэтому без танцев не обойтись.

(0) Кстати при формировании СКД можно задать два параметра , не видимых пользователю, значения которых присвоить вручную из уже существующих. (Правда только в том случае, если они предопределенные)

(10) Для тех кто на бронепоезде, нужны фиксированные настройки для отбора по конкретным полям характеристик, и действующие как настройка по умолчанию для всех пользователей (без ковыряния в режиме предприятия). Сделать это можно только так как я описал.

(13) кодируйте на здоровье, а я мышкой пойду щелкать

(13) Давай поспорим, что твой метод не единственный?
Более того, это более конкретная разновидность того, что я написал в (6)

(14)Иди объясняй 500 пользователям как добавить характеристику в отбор.
(16) -копирование настроек пользователей?
-не, не слышал

(15) Я и не спорю. Я просто не понял зачем нужны танцы с ТЗ и передачей ее в запрос (тем более что это будет еще один набор данных), если сделать все можно проще.

(17) Иди копируй настройки 500 пользователям.
(19) почему 500 пользователям, любому пользователю, который захочет пользоваться и новому тоже.
(19) пара кликов в типовой

(21) пару кликов, но не забывай про новых юзеров, который зайдут и будут волну нагонять, что не хватает полей

(22) думаю в конторе с «over 500» пользователей у поддержки есть какие-то регламенты по вводу новых пользователей в т.ч. по копированию их настроек

(18) С ТЗ — универсальный метод для любого количества характеристик (правда характеристики выбираются списком) Может кроме автор и класс там нужно выбрать и другие характеристики. Хотя в случае СКД это можно сделать и проще, добавив параметр, которому можно устанавливать список значений.
А вариант с соединением отдельным для каждого параметра — совсем другой метод, хотя и его можно реализовать сложно — динамической подменой запроса при компоновке (это если кол-во ревизитов задается пользователем)
В любом случае. я же не знал, что нужно автору

(23) Только представь себе регламент, который описывает настройки каждого отчета для каждого профиля пользователя. Поддержка тебя убъет просто.
В общем пустой это разговор.

Условие в запросе 1с как допреквизит

Всем привет!
Никак не соображу как сделать.
В Документе Реализация создал доп. реквизит — Оплачена. Реквизит как дополнительное значение с о списком Да.
Заполнил несколько документов. Хочу получить оставшиеся.
Так находятся все.

ВЫБРАТЬ
РеализацияТоваровУслуг.Ссылка КАК Ссылка,
РеализацияТоваровУслуг.ДополнительныеРеквизиты.(
Значение КАК Значение
) КАК ДополнительныеРеквизиты
ИЗ
Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг

А как мне найти, те в которых доп. реквизит не заполнен?

(0) выбирай из ТЧ, проверяй
(1) не взлетит, там где нет, его вообще не будет помоему
Сначала список доков, потом тч, соединяешь и вуаля

(2) Да в том то и дело, что либо выбирает то что заполнено, либо пустой результат по запросу.
(3) Сначала, в смысле сделать вложенным запросом?

(3) проще тогда ВТ из заполненных и запрос с условием НЕ Ссылка В (ВЫБРАТЬ Ссылка ИЗ ВТ)
(5) мне кажется мой способ быстрее)
(5) Вот у меня были такие мысли с В (ВЫБРАТЬ Ссылка ИЗ ВТ). Не знал куда НЕ приписать)

Настоятельно рекомендую пользоваться конструктором запросов. Использовать две таблицу, таблицу документа и таблицу табличной части. связать их по «Ссылке». Я сомневаясь, что Вам удалось определить реквизиту документа тип значения «СписокЗначений», поэтому отбор необходимо сделать на <> НЕОПРЕДЕЛЕНО

(8) Сделал как в (5) — работает.
Связывание таблиц что то не получается. Записей 0 в итоге

ВЫБРАТЬ
РеализацияТоваровУслуг.Ссылка КАК Ссылка
ИЗ
Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг

ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.ДополнительныеРеквизиты КАК РеализацияТоваровУслугДополнительныеРеквизиты
ПО (РеализацияТоваровУслугДополнительныеРеквизиты.Ссылка = РеализацияТоваровУслуг.Ссылка)
ГДЕ РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение = Неопределено

СГРУППИРОВАТЬ ПО
РеализацияТоваровУслуг.Ссылка

(9)Видимо там не Неопределено, а NULL

(10) ГДЕ РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение = NULL

Так написать, тоже результатов 0

(11)Потому что ничто не может равняться NULL. NULL вне системы. Даже NULL не может быть равен NULL, каждый NULL индивидуален.

А по факту нужно использовать ЕСТЬ NULL.

ГДЕ РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение = NULL
это жестко)

(9) Вы не верно выбрали реквизит в отборе «ГДЕ». Необходимо смотреть в таблицу табличной части документа, Вы же проверяете реквизит самого документа.

(13) Обычно же пишешь что нибудь типа ГДЕ ЕСТЬNULL(РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение,»Фигня какая-то получается»)=»Фигня какая-то получается»

(15)А чем не угодило краткое «ГДЕ Значение есть NULL»?

(15) Операция не разрешена в предложении «ГДЕ»
ГДЕ >ЕСТЬNULL(РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение,0)

(17)Правильно, потому что выражение в ГДЕ должно быть булевым. Приравняйте чему-нибудь, чтоле.
ГДЕ РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение есть NULL

ВЫБРАТЬ
РеализацияТоваровУслуг.Ссылка КАК Ссылка
ИЗ
Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг

ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.ДополнительныеРеквизиты КАК РеализацияТоваровУслугДополнительныеРеквизиты
ПО (РеализацияТоваровУслугДополнительныеРеквизиты.Ссылка = РеализацияТоваровУслуг.Ссылка)
ГДЕ РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение есть NULL
СГРУППИРОВАТЬ ПО
РеализацияТоваровУслуг.Ссылка

(20) я только сейчас посмотрел на правую часть этого бреда. РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение это вообще что?!
РеализацияТоваровУслугДополнительныеРеквизиты.Значение есть Null пробуй так
И срочно учить запросы, прям срочно.

(21) Да, теперь всё работает)
Спасибо!
Запросы учу. Я в 1с 8, можно сказать третий месяц только))

ребята,а где проверка на наш допреквизит?
создайте другой допреквизит,запустите запрос и осознайте печаль.

в соединении вставить реализациятоваровуслугдопреквизиты.свойство=&нашдопреквизит

(23)Мы нужное поле в запросе почти сутки искали. Давайте вот без этого вот.
(25) нет, уж делать так на совесть. Давайте продолжим

Да, да в первоначальном варианте запроса была проверка)
И РеализацияТоваровУслугДополнительныеРеквизиты.Свойство = &Свойтсво

(27) не взлетит
(28) А как надо тогда?

(29) по другому) Сначала отобрать только нужные свойства а затем соединять
или же в условие связи прописать, твое условие из где, но это мне кажется плохой вариант

(27)строка должна быть в условии соединения таблиц.

ГДЕ ISNULL(РеализацияТоваровУслуг.ДополнительныеРеквизиты.Значение,Неопределено) = Неопределено

(32) не взлетит)

Да, как то сложновато всё получается.
Плюс у меня должно выбираться незаполненное значение и заполненное значением «Частично». И это всё нужно засунуть в СКД.
В консоли запросов понятно присвоил параметру &значен тип дополнительное значение, и значение «Частично», а в СКД такого не вижу.

ГДЕ
(РеализацияТоваровУслугДополнительныеРеквизиты.Значение ЕСТЬ NULL
ИЛИ РеализацияТоваровУслугДополнительныеРеквизиты.Значение = &Значен)

Столкнулся с еще одной непонятной для меня проблемой. Дописал запрос, засунул его в СКД, настроил параметры, выбрал поля детальных записей. Ссылка на документ, контрагента. В режиме предприятия выводится только ссылка на документ, контрагент никак не выводится.
Нагуглил на статью в ИСе, что нужно в константах установить галку опции Использовать партнеров и контрагентов. Поставил — контрагенты стали отображаться. Но мне для работы не нужны партнеры, а с этой галкой все немного поменялось.
Никто не знает другие способы решения?

Добавь в запросе вывод поля Контрагент

(36) В запросе есть это поле. Не выводится не так, не через Ссылка.Контрагент. А когда константу выставляешь в Истина, тогда и то и другое выводится.

(37) Запрос-то покажи. Запрос проверял в консоли. Это поле заполнено при выводе?
Запрос проверял в консоли?

(38) В консоли все работает

ВЫБРАТЬ
РеализацияТоваровУслуг.Ссылка КАК Ссылка,
РеализацияТоваровУслуг.Дата КАК Дата,
РеализацияТоваровУслуг.Номер КАК Номер,
РеализацияТоваровУслуг.Контрагент КАК Контрагент,
РеализацияТоваровУслуг.ДополнительныеРеквизиты.(
Значение КАК Значение
) КАК ДополнительныеРеквизиты
ИЗ
Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.ДополнительныеРеквизиты КАК РеализацияТоваровУслугДополнительныеРеквизиты
ПО (РеализацияТоваровУслугДополнительныеРеквизиты.Ссылка = РеализацияТоваровУслуг.Ссылка)
ГДЕ
(РеализацияТоваровУслугДополнительныеРеквизиты.Значение ЕСТЬ NULL
ИЛИ РеализацияТоваровУслугДополнительныеРеквизиты.Значение.Наименование = &Значен)
И РеализацияТоваровУслуг.Дата >= &НачальнаяДата
И РеализацияТоваровУслуг.Дата И РеализацияТоваровУслуг.ПометкаУдаления = ЛОЖЬ
И РеализацияТоваровУслуг.Проведен = ИСТИНА

РеализацияТоваровУслуг.ДополнительныеРеквизиты.(
Значение КАК Значение
) КАК ДополнительныеРеквизиты
Вот это зачем?

И РеализацияТоваровУслуг.ПометкаУдаления = ЛОЖЬ
лишнее. Документ, не может быть помеченным на удаление и проведенным одновременно

1С БСП Дополнительные реквизиты и сведения

В этой статье я хотел бы рассказать об архитектуре, использовании и особенностях реализации подсистемы «Свойства» из инструментария разработчика «1С:Библиотека стандартных подсистем» (1С БСП).

Для начала предлагаю разобраться с терминологией 1С БСП: согласно ИТС дополнительные реквизиты и сведения — это свойства. По моему мнению, подсистема «Свойства» (Управление свойствами) — это очень мощный функционал, который позволяет во многих случаях отказаться от снятия конфигурации с поддержки или внесения ненужных изменений и ошибок в конфигурацию.

Архитектура 1C БСП Дополнительные реквизиты и сведения

Описание работы с подсистемой «Свойства» на сайте ИТС 1С является исчерпывающим для типовых конфигураций, но в любом случае, для того, чтобы начать работать со свойствами в любой конфигурации с внедрённым 1С БСП необходимо установить установить константу «Использовать дополнительные реквизиты и сведения» в значение «Истина». После этого мы можем открыть справочник «Наборы дополнительных реквизитов и сведений», который содержит список объектов для которых можно создавать дополнительные реквизиты и сведения. При добавлении через стандартные формы 1С БСП пользователь создаёт новый элемент «Плана видов характеристик», который добавляется в табличную часть элемента.

Дополнительные сведения отличаются от дополнительных реквизитов прежде всего расположением, дополнительные сведения содержатся в отдельном регистре с одноименным названием, а дополнительные реквизиты являются табличной частью объекта, к которому относятся. На рисунке ниже слева-направо изображены: элемент справочника «Наборы дополнительных реквизитов и свойств», элемент плана видов характеристик и список регистра сведений «Дополнительные сведения».

Следующий рисунок изображает пример дополнительного реквизита, слева-направо: элемент справочника «Наборы дополнительных реквизитов и свойств», элемент плана видов характеристик и элемент справочника, в который был добавлен дополнительный реквизит.

Также стоит учитывать, что большая часть объектов метаданных в справочнике «Наборы дополнительных реквизитов и сведений» является предопределённой:

Однако, заполнение этих данных происходит программно, при внедрении 1С БСП или обновлении информационной базы — для этого в общих модулях добавляют процедуру ПриПолученииПредопределенныхНаборовСвойств. Уникальный идентификатор задаётся в явном виде, в т.ч. для того чтобы облегчить процедуры обмена между базами.

// См. УправлениеСвойствамиПереопределяемый.ПриПолученииПредопределенныхНаборовСвойств. // // Параметры: // Наборы - см. УправлениеСвойствамиПереопределяемый.ПриПолученииПредопределенныхНаборовСвойств.Наборы // Процедура ПриПолученииПредопределенныхНаборовСвойств(Наборы) Экспорт Набор = Наборы.Строки.Добавить(); Набор.Имя = "Справочник_ПапкиФайлов"; Набор.Идентификатор = Новый УникальныйИдентификатор("00000000-0000-0000-0000-000000000000"); КонецПроцедуры

С точки зрения интеграции с объектами механизм работы с формами не сильно отличается от аналогичных у других подсистем 1С БСП: из модуля УправлениеСвойствами вызываются процедуры и функции с названиями соответствующими названиям событий для которых они вызываются, например:

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) // Обработчик подсистемы "Свойства" ДополнительныеПараметры = Новый Структура; ДополнительныеПараметры.Вставить("Объект", Объект); ДополнительныеПараметры.Вставить("ИмяЭлементаДляРазмещения", "ГруппаДополнительныеРеквизиты"); УправлениеСвойствами.ПриСозданииНаСервере(ЭтаФорма, ДополнительныеПараметры); КонецПроцедуры

Полный список функций и процедур находится в общем модуле УправлениеСвойствами в блоке, озаглавленным: «Процедуры и функции для стандартной обработки дополнительных реквизитов».

Использование подсистемы 1С БСП Дополнительные реквизиты

Каждый дополнительный реквизит или свойство содержит поле «Имя», подразумевается, что для программного использования будет использоваться этот реквизит.

Пример использования имени для получения дополнительного реквизита 1С БСП

ВЫБРАТЬ ГражданствоФизическихЛиц.ФизическоеЛицо КАК ФизическоеЛицо, ФизическиеЛицаДополнительныеРеквизиты.Значение КАК Рост, ГражданствоФизическихЛиц.Страна КАК Страна ИЗ Справочник.ФизическиеЛица.ДополнительныеРеквизиты КАК ФизическиеЛицаДополнительныеРеквизиты ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ГражданствоФизическихЛиц КАК ГражданствоФизическихЛиц ПО ГражданствоФизическихЛиц.ФизическоеЛицо = ФизическиеЛицаДополнительныеРеквизиты.Ссылка ГДЕ ГражданствоФизическихЛиц.ФизическоеЛицо = &ФизическоеЛицо И ФизическиеЛицаДополнительныеРеквизиты.Свойство.Имя = &Имя

Пример запроса для получения всех дополнительных свойств

ВЫБРАТЬ ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура, ЦеныНоменклатурыСрезПоследних.ТипЦен КАК ТипЦен, ЦеныНоменклатурыСрезПоследних.Цена КАК Цена, ДополнительныеСведения.Свойство КАК Свойство, ДополнительныеСведения.Значение КАК Значение, ДополнительныеСведения.Свойство.Имя КАК ИмяСвойства ИЗ РегистрСведений.ЦеныНоменклатуры.СрезПоследних( &Дата, Номенклатура = &Номенклатура И ТипЦен = &ТипЦен) КАК ЦеныНоменклатурыСрезПоследних ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения ПО ЦеныНоменклатурыСрезПоследних.Номенклатура = ДополнительныеСведения.Объект ИТОГИ МАКСИМУМ(Номенклатура), МАКСИМУМ(Цена) ПО ОБЩИЕ, ТипЦен

Примеры получения свойств 1С БСП без запроса

Рост = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.найтиПоРеквизиту("Имя", "Рост_12f49d4f164847b79effd75a758186c3"); // Получение дополнительного реквизита Рост = УправлениеСвойствами.ЗначениеСвойства(ФизическоеЛицо.Ссылка, Рост); // Получение всех дополнительных реквизитов и сведений объекта ВсеСвойства = УправлениеСвойствами.ЗначенияСвойств(ФизическоеЛицо.Ссылка);

Особенности реализации 1С БСП Дополнительные реквизиты

Если с запросами и функциями всё более менее ясно неприятным сюрпризом может стать то, что дополнительный реквизит на форме содержит название, отличающееся от этого реквизита, например, такое:

Чтобы найти реквизит на форме 1С БСП создаёт новые реквизиты формы Свойства_ОписаниеДополнительныхРеквизитов и Свойства_ОписаниеЗависимыхДополнительныхРеквизитов, с помощью них можно установить однозначное соответствие между элементом и значением объекта:

Второй особенностью реализации можно выделить невозможность создания свойства с мутабельным типом, с одной стороны это очевидное ограничение, с другой тип «Список значений» вполне допустим, но только для дополнительного реквизита (у дополнительных сведений невозможность связана с архитектурными ограничениями, так как объект и свойство — это измерения регистра «Дополнительные сведения»). Возможно, отсутствие такого типа связано со сложностями при обмене, а возможно в скором времени это будет реализовано, предлагаю посмотреть на пример такой реализации ниже.

Как получить дополнительный реквизит в 1С БСП

1.Добавим дополнительный реквизит

Добавим новый дополнительный реквизит для справочника физические лица «Номера счетов»

1с бсп получить значение дополнительного реквизита

2.Получим значение дополнительного реквизита 1С БСП программно

Добавляем программно, вторую запись в табличную часть «Дополнительные реквизиты» справочника «Физические лица» с тем же самым свойством:

1с получить значение дополнительного реквизита программно бсп

3. Модифицируем код функций и процедур

Немного модифицируем код функции ЗначенияСвойств в общем модуле УправлениеСвойствамиСлужебный:

А также код процедуры ЗаполнитьДополнительныеРеквизитыВФорме в общем модуле УправлениеСвойствами:

Таким образом мы можем сохранять и восстанавливать значения реквизитов, которые, принимают множество значений.

// Создает/пересоздает дополнительные реквизиты и элементы в форме владельца свойств. // // Параметры: // Форма - ФормаКлиентскогоПриложения - уже настроена в процедуре ПриСозданииНаСервере. // // Объект - Неопределено - взять объект из реквизита формы "Объект". // - СправочникОбъектИмяСправочника - // - ДокументОбъектИмяДокумента - // - ПланВидовХарактеристикОбъектИмяПланаВидовХарактеристик - // - БизнесПроцессОбъектИмяБизнесПроцесса - // - ЗадачаОбъектИмяЗадачи - // - ПланВидовРасчетаОбъектИмяПланаВидовРасчета - // - ПланСчетовОбъектИмяПланаСчетов - // - ДанныеФормыСтруктура - // // ПоляНадписей - Булево - если указать Истина, то вместо полей ввода на форме будут созданы поля надписей. // // СкрытьУдаленные - Неопределено - не менять текущий режим скрытия удаленных, установленный ранее. // - Булево - установить/отключить режим скрытия удаленных. // При вызове процедуры ПередЗаписьюНаСервере в режиме скрытия удаленных, удаленные значения // очищаются (не переносятся обратно в объект), а режим СкрытьУдаленные устанавливается Ложь. // Процедура ЗаполнитьДополнительныеРеквизитыВФорме(Форма, Объект = Неопределено, ПоляНадписей = Ложь, СкрытьУдаленные = Неопределено) Экспорт Если НЕ Форма.Свойства_ИспользоватьСвойства ИЛИ НЕ Форма.Свойства_ИспользоватьДопРеквизиты Тогда Возврат; КонецЕсли; Если ТипЗнч(СкрытьУдаленные) = Тип("Булево") Тогда Форма.Свойства_СкрытьУдаленные = СкрытьУдаленные; КонецЕсли; Если Объект = Неопределено Тогда ОписаниеОбъекта = Форма.Объект; Иначе ОписаниеОбъекта = Объект; КонецЕсли; Форма.Свойства_НаборыДополнительныхРеквизитовОбъекта = Новый СписокЗначений; КлючНазначения = Неопределено; НаборыСвойствОбъекта = УправлениеСвойствамиСлужебный.ПолучитьНаборыСвойствОбъекта( ОписаниеОбъекта, КлючНазначения); УправлениеСвойствамиСлужебный.ЗаполнитьНаборыСДополнительнымиРеквизитами( НаборыСвойствОбъекта, Форма.Свойства_НаборыДополнительныхРеквизитовОбъекта); ОбновитьКлючНазначенияФормы(Форма, КлючНазначения); ОписаниеСвойств = УправлениеСвойствамиСлужебный.ЗначенияСвойств( ОписаниеОбъекта.ДополнительныеРеквизиты.Выгрузить(), Форма.Свойства_НаборыДополнительныхРеквизитовОбъекта, Ложь); ОписаниеСвойств.Колонки.Добавить("ИмяРеквизитаЗначение"); ОписаниеСвойств.Колонки.Добавить("СтрокаСсылочногоТипа"); ОписаниеСвойств.Колонки.Добавить("ИмяСсылочногоРеквизитаЗначение"); ОписаниеСвойств.Колонки.Добавить("ИмяУникальнаяЧасть"); ОписаниеСвойств.Колонки.Добавить("ДополнительноеЗначение"); ОписаниеСвойств.Колонки.Добавить("Булево"); УдалитьСтарыеРеквизитыИЭлементы(Форма); // Создание реквизитов. ДобавляемыеРеквизиты = Новый Массив(); Для каждого ОписаниеСвойства Из ОписаниеСвойств Цикл ТипЗначенияСвойства = ОписаниеСвойства.ТипЗначения; СписокТипов = ТипЗначенияСвойства.Типы(); СтроковыйРеквизит = (СписокТипов.Количество() = 1) И (СписокТипов[0] = Тип("Строка")); // Поддержка строк неограниченной длины. ИспользоватьНеограниченнуюСтроку = УправлениеСвойствамиСлужебный.ИспользоватьНеограниченнуюСтроку( ТипЗначенияСвойства, ОписаниеСвойства.МногострочноеПолеВвода); Если ИспользоватьНеограниченнуюСтроку Тогда ТипЗначенияСвойства = Новый ОписаниеТипов("Строка"); ИначеЕсли ТипЗначенияСвойства.СодержитТип(Тип("Строка")) И ТипЗначенияСвойства.КвалификаторыСтроки.Длина = 0 Тогда // Если нельзя использовать неограниченную строку, а в свойствах реквизита она неограниченная, // то устанавливаем ограничение в 1024 символа. ТипЗначенияСвойства = Новый ОписаниеТипов(ОписаниеСвойства.ТипЗначения, . Новый КвалификаторыСтроки(1024)); КонецЕсли; ОписаниеСвойства.ИмяУникальнаяЧасть = СтрЗаменить(ВРег(Строка(ОписаниеСвойства.Набор.УникальныйИдентификатор())), "-", "x") + "_" + СтрЗаменить(ВРег(Строка(ОписаниеСвойства.Свойство.УникальныйИдентификатор())), "-", "x"); // Неопределено Тогда ОписаниеСвойства.ИмяУникальнаяЧасть = ОписаниеСвойства.ИмяУникальнаяЧасть + "_" + ОписаниеСвойств.Индекс(описаниеСвойства); КонецЕсли; // >> Тип("СписокЗначений") Тогда Если ИмяЭлементаДляРазмещения = Неопределено Тогда ИмяЭлементаДляРазмещения = ""; КонецЕсли; ЭлементРазмещения = ?(ИмяЭлементаДляРазмещения = "", Неопределено, Форма.Элементы[ИмяЭлементаДляРазмещения]); Иначе РазделыДляРазмещения = Форма.Свойства_ИмяЭлементаДляРазмещения; РазмещениеНабора = РазделыДляРазмещения.НайтиПоЗначению(ОписаниеСвойства.Набор); Если РазмещениеНабора = Неопределено Тогда РазмещениеНабора = РазделыДляРазмещения.НайтиПоЗначению("ВсеОстальные"); КонецЕсли; ЭлементРазмещения = Форма.Элементы[РазмещениеНабора.Представление]; КонецЕсли; ФормаОписаниеСвойства = Форма.Свойства_ОписаниеДополнительныхРеквизитов.Добавить(); ЗаполнитьЗначенияСвойств(ФормаОписаниеСвойства, ОписаниеСвойства); // Заполнение таблицы зависимых дополнительных реквизитов. Если ОписаниеСвойства.ЗависимостиДополнительныхРеквизитов.Количество() > 0 И Не ОписаниеСвойства.Удалено Тогда ОписаниеЗависимогоРеквизита = Форма.Свойства_ОписаниеЗависимыхДополнительныхРеквизитов.Добавить(); ЗаполнитьЗначенияСвойств(ОписаниеЗависимогоРеквизита, ОписаниеСвойства); КонецЕсли; ОтборСтрок = Новый Структура; ОтборСтрок.Вставить("НаборСвойств", ОписаниеСвойства.Набор); ЗависимостиДанногоНабора = ОписаниеСвойства.ЗависимостиДополнительныхРеквизитов.НайтиСтроки(ОтборСтрок); Для Каждого СтрокаТаблицы Из ЗависимостиДанногоНабора Цикл Если СтрокаТаблицы.ЗависимоеСвойство = "ЗаполнятьОбязательно" И ОписаниеСвойства.ТипЗначения = Новый ОписаниеТипов("Булево") Тогда Продолжить; КонецЕсли; Если ОписаниеСвойства.Удалено Тогда Продолжить; КонецЕсли; Если ТипЗнч(СтрокаТаблицы.Реквизит) = Тип("Строка") Тогда ПутьКРеквизиту = "Параметры.ОписаниеОбъекта." + СтрокаТаблицы.Реквизит; Иначе ОписаниеДополнительногоРеквизита = ОписаниеСвойств.Найти(СтрокаТаблицы.Реквизит, "Свойство"); Если ОписаниеДополнительногоРеквизита = Неопределено Тогда Продолжить; // Дополнительный реквизит не существует, условие игнорируется. КонецЕсли; ПутьКРеквизиту = "Параметры.Форма." + ОписаниеДополнительногоРеквизита.ИмяРеквизитаЗначение; КонецЕсли; УправлениеСвойствамиСлужебный.ПостроитьУсловияЗависимостей(ОписаниеЗависимогоРеквизита, ПутьКРеквизиту, СтрокаТаблицы); КонецЦикла; Если ОписаниеСвойства.СтрокаСсылочногоТипа Тогда Если ЗначениеЗаполнено(ОписаниеСвойства.Значение) Тогда Значение = ОписаниеСвойства.ТипЗначения.ПривестиЗначение(ОписаниеСвойства.Значение); СтрокаЗначение = СтроковыеФункции.ФорматированнаяСтрока(Значение); Иначе Значение = НСтр("ru = 'не задано'"); СсылкаРедактирования = "НеЗадано"; СтрокаЗначение = Новый ФорматированнаяСтрока(Значение,, ЦветаСтиля.ЦветПустойГиперссылки,, СсылкаРедактирования); КонецЕсли; Форма[ОписаниеСвойства.ИмяСсылочногоРеквизитаЗначение] = СтрокаЗначение; КонецЕсли; Форма[ОписаниеСвойства.ИмяРеквизитаЗначение] = ОписаниеСвойства.Значение; Если ОписаниеСвойства.Удалено И Форма.Свойства_СкрытьУдаленные Тогда Продолжить; КонецЕсли; Если НаборыСвойствОбъекта.Количество() > 1 Тогда ЭлементСписка = Форма.Свойства_ЭлементыГруппДополнительныхРеквизитов.НайтиПоЗначению( ОписаниеСвойства.Набор); Если ЭлементСписка <> Неопределено Тогда Родитель = Форма.Элементы[ЭлементСписка.Представление]; Иначе ОписаниеНабора = НаборыСвойствОбъекта.Найти(ОписаниеСвойства.Набор, "Набор"); Если ОписаниеНабора = Неопределено Тогда ОписаниеНабора = НаборыСвойствОбъекта.Добавить(); ОписаниеНабора.Набор = ОписаниеСвойства.Набор; ОписаниеНабора.Заголовок = НСтр("ru = 'Удаленные реквизиты'") КонецЕсли; Если НЕ ЗначениеЗаполнено(ОписаниеНабора.Заголовок) Тогда ОписаниеНабора.Заголовок = Строка(ОписаниеСвойства.Набор); КонецЕсли; ИмяЭлементаНабора = "НаборДополнительныхРеквизитов" + ОписаниеСвойства.ИмяУникальнаяЧасть; Родитель = Форма.Элементы.Добавить(ИмяЭлементаНабора, Тип("ГруппаФормы"), ЭлементРазмещения); Форма.Свойства_ЭлементыГруппДополнительныхРеквизитов.Добавить( ОписаниеСвойства.Набор, Родитель.Имя); Если ТипЗнч(ЭлементРазмещения) = Тип("ГруппаФормы") И ЭлементРазмещения.Вид = ВидГруппыФормы.Страницы Тогда Родитель.Вид = ВидГруппыФормы.Страница; Иначе Родитель.Вид = ВидГруппыФормы.ОбычнаяГруппа; Родитель.Отображение = ОтображениеОбычнойГруппы.Нет; КонецЕсли; Родитель.ОтображатьЗаголовок = Ложь; Родитель.Группировка = ГруппировкаПодчиненныхЭлементовФормы.Вертикальная; ЗаполненныеСвойстваГруппы = Новый Структура; Для каждого Колонка Из НаборыСвойствОбъекта.Колонки Цикл Если ОписаниеНабора[Колонка.Имя] <> Неопределено Тогда ЗаполненныеСвойстваГруппы.Вставить(Колонка.Имя, ОписаниеНабора[Колонка.Имя]); КонецЕсли; КонецЦикла; ЗаполнитьЗначенияСвойств(Родитель, ЗаполненныеСвойстваГруппы); КонецЕсли; Иначе Родитель = ЭлементРазмещения; КонецЕсли; Если ОписаниеСвойства.ВыводитьВВидеГиперссылки Тогда ИмяГруппыГиперссылки = "Группа_" + ОписаниеСвойства.ИмяУникальнаяЧасть; ГруппаГиперссылки = Форма.Элементы.Добавить(ИмяГруппыГиперссылки, Тип("ГруппаФормы"), Родитель); ГруппаГиперссылки.Вид = ВидГруппыФормы.ОбычнаяГруппа; ГруппаГиперссылки.Отображение = ОтображениеОбычнойГруппы.Нет; ГруппаГиперссылки.ОтображатьЗаголовок = Ложь; ГруппаГиперссылки.Группировка = ГруппировкаПодчиненныхЭлементовФормы.ГоризонтальнаяВсегда; ГруппаГиперссылки.Заголовок = ОписаниеСвойства.Наименование; Элемент = Форма.Элементы.Добавить(ОписаниеСвойства.ИмяРеквизитаЗначение, Тип("ПолеФормы"), ГруппаГиперссылки); // РасширениеПоляФормыДляПоляНадписи, РасширениеПоляФормыДляПоляВвода РеквизитДоступен = РеквизитДоступенПоФункциональнымОпциям(ОписаниеСвойства); Если РеквизитДоступен И Не ПоляНадписей Тогда ИмяКнопки = "Кнопка_" + ОписаниеСвойства.ИмяУникальнаяЧасть; Кнопка = Форма.Элементы.Добавить( ИмяКнопки, Тип("КнопкаФормы"), ГруппаГиперссылки); Кнопка.ТолькоВоВсехДействиях = Истина; Кнопка.ИмяКоманды = "РедактироватьГиперссылкуРеквизита"; Кнопка.ОтображениеФигуры = ОтображениеФигурыКнопки.ПриАктивности; КонецЕсли; Если Не ОписаниеСвойства.СтрокаСсылочногоТипа И ЗначениеЗаполнено(ОписаниеСвойства.Значение) Тогда Элемент.Гиперссылка = Истина; КонецЕсли; Иначе Элемент = Форма.Элементы.Добавить(ОписаниеСвойства.ИмяРеквизитаЗначение, Тип("ПолеФормы"), Родитель); // РасширениеПоляФормыДляПоляНадписи, РасширениеПоляФормыДляПоляВвода КонецЕсли; ФормаОписаниеСвойства.ЭлементФормыДобавлен = Истина; Если ОписаниеСвойства.Булево И ПустаяСтрока(ОписаниеСвойства.ФорматСвойства) Тогда Элемент.Вид = ВидПоляФормы.ПолеФлажка; Элемент.ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Право; Иначе Если ПоляНадписей Тогда Элемент.Вид = ВидПоляФормы.ПолеВвода; ИначеЕсли ОписаниеСвойства.ВыводитьВВидеГиперссылки И (ОписаниеСвойства.СтрокаСсылочногоТипа Или ЗначениеЗаполнено(ОписаниеСвойства.Значение))Тогда Элемент.Вид = ВидПоляФормы.ПолеНадписи; Иначе Элемент.Вид = ВидПоляФормы.ПолеВвода; Элемент.АвтоОтметкаНезаполненного = ОписаниеСвойства.ЗаполнятьОбязательно И НЕ ОписаниеСвойства.Удалено; КонецЕсли; Элемент.РастягиватьПоВертикали = Ложь; Элемент.ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Лево; КонецЕсли; Если ОписаниеСвойства.СтрокаСсылочногоТипа Тогда Элемент.ПутьКДанным = ОписаниеСвойства.ИмяСсылочногоРеквизитаЗначение; Элемент.УстановитьДействие("ОбработкаНавигационнойСсылки", "Подключаемый_СвойстваВыполнитьКоманду"); Иначе Элемент.ПутьКДанным = ОписаниеСвойства.ИмяРеквизитаЗначение; КонецЕсли; Элемент.Подсказка = ОписаниеСвойства.Подсказка; Элемент.УстановитьДействие("ПриИзменении", "Подключаемый_ПриИзмененииДополнительногоРеквизита"); Если Элемент.Вид = ВидПоляФормы.ПолеВвода И Не ИспользоватьНеограниченнуюСтроку И ОписаниеСвойства.ТипЗначения.Типы().Найти(Тип("Строка")) <> Неопределено Тогда Элемент.СвязьПоТипу = Новый СвязьПоТипу("Свойства_ОписаниеДополнительныхРеквизитов.Свойство", ОписаниеСвойств.Индекс(ОписаниеСвойства)); КонецЕсли; Если ОписаниеСвойства.МногострочноеПолеВвода > 0 Тогда Если НЕ ПоляНадписей Тогда Элемент.МногострочныйРежим = Истина; КонецЕсли; Элемент.Высота = ОписаниеСвойства.МногострочноеПолеВвода; КонецЕсли; Если НЕ ПустаяСтрока(ОписаниеСвойства.ФорматСвойства) И Не ОписаниеСвойства.ВыводитьВВидеГиперссылки Тогда Если ПоляНадписей Тогда Элемент.Формат = ОписаниеСвойства.ФорматСвойства; Иначе ФорматнаяСтрока = ""; Массив = СтрРазделить(ОписаниеСвойства.ФорматСвойства, ";", Ложь); Для каждого Подстрока Из Массив Цикл Если СтрНайти(Подстрока, "ДП=") > 0 ИЛИ СтрНайти(Подстрока, "DE=") > 0 Тогда Продолжить; КонецЕсли; Если СтрНайти(Подстрока, "ЧН=") > 0 ИЛИ СтрНайти(Подстрока, "NZ=") > 0 Тогда Продолжить; КонецЕсли; Если СтрНайти(Подстрока, "ДФ=") > 0 ИЛИ СтрНайти(Подстрока, "DF=") > 0 Тогда Если СтрНайти(Подстрока, "ддд") > 0 ИЛИ СтрНайти(Подстрока, "ddd") > 0 Тогда Подстрока = СтрЗаменить(Подстрока, "ддд", "дд"); Подстрока = СтрЗаменить(Подстрока, "ddd", "dd"); КонецЕсли; Если СтрНайти(Подстрока, "дддд") > 0 ИЛИ СтрНайти(Подстрока, "dddd") > 0 Тогда Подстрока = СтрЗаменить(Подстрока, "дддд", "дд"); Подстрока = СтрЗаменить(Подстрока, "dddd", "dd"); КонецЕсли; Если СтрНайти(Подстрока, "МММ") > 0 ИЛИ СтрНайти(Подстрока, "MMM") > 0 Тогда Подстрока = СтрЗаменить(Подстрока, "МММ", "ММ"); Подстрока = СтрЗаменить(Подстрока, "MMM", "MM"); КонецЕсли; Если СтрНайти(Подстрока, "ММММ") > 0 ИЛИ СтрНайти(Подстрока, "MMMM") > 0 Тогда Подстрока = СтрЗаменить(Подстрока, "ММММ", "ММ"); Подстрока = СтрЗаменить(Подстрока, "MMMM", "MM"); КонецЕсли; КонецЕсли; Если СтрНайти(Подстрока, "ДЛФ=") > 0 ИЛИ СтрНайти(Подстрока, "DLF=") > 0 Тогда Если СтрНайти(Подстрока, "ДД") > 0 ИЛИ СтрНайти(Подстрока, "DD") > 0 Тогда Подстрока = СтрЗаменить(Подстрока, "ДД", "Д"); Подстрока = СтрЗаменить(Подстрока, "DD", "D"); КонецЕсли; КонецЕсли; ФорматнаяСтрока = ФорматнаяСтрока + ?(ФорматнаяСтрока = "", "", ";") + Подстрока; КонецЦикла; Элемент.Формат = ФорматнаяСтрока; Элемент.ФорматРедактирования = ФорматнаяСтрока; КонецЕсли; КонецЕсли; Если ОписаниеСвойства.Удалено Тогда Элемент.ЦветТекстаЗаголовка = ЦветаСтиля.ТекстЗапрещеннойЯчейкиЦвет; Элемент.ШрифтЗаголовка = ШрифтыСтиля.ЗаголовокУдаленногоРеквизитаШрифт; Если Элемент.Вид = ВидПоляФормы.ПолеВвода Тогда Элемент.КнопкаОчистки = Истина; Элемент.КнопкаВыбора = Ложь; Элемент.КнопкаОткрытия = Ложь; Элемент.КнопкаВыпадающегоСписка = Ложь; Элемент.РедактированиеТекста = Ложь; КонецЕсли; КонецЕсли; Если НЕ ПоляНадписей И ОписаниеСвойства.ДополнительноеЗначение И Элемент.Вид = ВидПоляФормы.ПолеВвода Тогда ПараметрыВыбора = Новый Массив; ПараметрыВыбора.Добавить(Новый ПараметрВыбора("Отбор.Владелец", ?(ЗначениеЗаполнено(ОписаниеСвойства.ВладелецДополнительныхЗначений), ОписаниеСвойства.ВладелецДополнительныхЗначений, ОписаниеСвойства.Свойство))); Элемент.ПараметрыВыбора = Новый ФиксированныйМассив(ПараметрыВыбора); КонецЕсли; КонецЦикла; // Установка видимости, доступности и обязательности заполнения дополнительных реквизитов. Для Каждого ОписаниеЗависимогоРеквизита Из Форма.Свойства_ОписаниеЗависимыхДополнительныхРеквизитов Цикл Если ОписаниеЗависимогоРеквизита.ВыводитьВВидеГиперссылки Тогда ОбрабатываемыйЭлемент = СтрЗаменить(ОписаниеЗависимогоРеквизита.ИмяРеквизитаЗначение, "ДополнительныйРеквизитЗначение_", "Группа_"); Иначе ОбрабатываемыйЭлемент = ОписаниеЗависимогоРеквизита.ИмяРеквизитаЗначение; КонецЕсли; Если ОписаниеЗависимогоРеквизита.УсловиеДоступности <> Неопределено Тогда Результат = РезультатВычисленияУсловия(Форма, ОписаниеОбъекта, ОписаниеЗависимогоРеквизита.УсловиеДоступности); Элемент = Форма.Элементы[ОбрабатываемыйЭлемент]; // ПолеФормы Если Элемент.Доступность <> Результат Тогда Элемент.Доступность = Результат; КонецЕсли; КонецЕсли; Если ОписаниеЗависимогоРеквизита.УсловиеВидимости <> Неопределено Тогда Результат = РезультатВычисленияУсловия(Форма, ОписаниеОбъекта, ОписаниеЗависимогоРеквизита.УсловиеВидимости); Элемент = Форма.Элементы[ОбрабатываемыйЭлемент]; Если Элемент.Видимость <> Результат Тогда Элемент.Видимость = Результат; КонецЕсли; КонецЕсли; Если ОписаниеЗависимогоРеквизита.УсловиеОбязательностиЗаполнения <> Неопределено Тогда Если Не ОписаниеЗависимогоРеквизита.ЗаполнятьОбязательно Тогда Продолжить; КонецЕсли; Результат = РезультатВычисленияУсловия(Форма, ОписаниеОбъекта, ОписаниеЗависимогоРеквизита.УсловиеОбязательностиЗаполнения); Элемент = Форма.Элементы[ОбрабатываемыйЭлемент]; Если Не ОписаниеЗависимогоРеквизита.ВыводитьВВидеГиперссылки И Элемент.АвтоОтметкаНезаполненного <> Результат Тогда Элемент.АвтоОтметкаНезаполненного = Результат; КонецЕсли; КонецЕсли; КонецЦикла; Структура = Новый Структура("ПараметрыСвойств"); ЗаполнитьЗначенияСвойств(Структура, Форма); Если ТипЗнч(Структура.ПараметрыСвойств) = Тип("Структура") И Структура.ПараметрыСвойств.Свойство("ВыполненаОтложеннаяИнициализация") Тогда Форма.ПараметрыСвойств.ВыполненаОтложеннаяИнициализация = Истина; // Удаление временной декорации, если она была добавлена. Если Форма.ПараметрыСвойств.Свойство("ДобавленаПустаяДекорация") Тогда Для Каждого ИмяДекорации Из Форма.ПараметрыСвойств.КоллекцияДекораций Цикл Форма.Элементы.Удалить(Форма.Элементы[ИмяДекорации]); КонецЦикла; Форма.ПараметрыСвойств.Удалить("ДобавленаПустаяДекорация"); КонецЕсли; КонецЕсли; КонецПроцедуры
// Возвращает заполненную таблицу значений свойств объекта. Функция ЗначенияСвойств(ДополнительныеСвойстваОбъекта, Наборы, ЭтоДополнительноеСведение) Экспорт Если ДополнительныеСвойстваОбъекта.Количество() = 0 Тогда // Предварительная быстрая проверка использования дополнительных свойств. СвойстваНеНайдены = ДополнительныеРеквизитыИСведенияНеНайдены(Наборы, ЭтоДополнительноеСведение); Если СвойстваНеНайдены Тогда ОписаниеСвойств = Новый ТаблицаЗначений; ОписаниеСвойств.Колонки.Добавить("Набор"); ОписаниеСвойств.Колонки.Добавить("Свойство"); ОписаниеСвойств.Колонки.Добавить("ВладелецДополнительныхЗначений"); ОписаниеСвойств.Колонки.Добавить("ЗаполнятьОбязательно"); ОписаниеСвойств.Колонки.Добавить("Наименование"); ОписаниеСвойств.Колонки.Добавить("ТипЗначения"); ОписаниеСвойств.Колонки.Добавить("ФорматСвойства"); ОписаниеСвойств.Колонки.Добавить("МногострочноеПолеВвода"); ОписаниеСвойств.Колонки.Добавить("Удалено"); ОписаниеСвойств.Колонки.Добавить("Значение"); Возврат ОписаниеСвойств; КонецЕсли; КонецЕсли; Свойства = ДополнительныеСвойстваОбъекта.ВыгрузитьКолонку("Свойство"); НаборыСвойств = Новый ТаблицаЗначений; НаборыСвойств.Колонки.Добавить( "Набор", Новый ОписаниеТипов("СправочникСсылка.НаборыДополнительныхРеквизитовИСведений")); НаборыСвойств.Колонки.Добавить( "ПорядокНабора", Новый ОписаниеТипов("Число")); Для каждого ЭлементСписка Из Наборы Цикл НоваяСтрока = НаборыСвойств.Добавить(); НоваяСтрока.Набор = ЭлементСписка.Значение; НоваяСтрока.ПорядокНабора = Наборы.Индекс(ЭлементСписка); КонецЦикла; Запрос = Новый Запрос; Запрос.УстановитьПараметр("Свойства", Свойства); Запрос.УстановитьПараметр("НаборыСвойств", НаборыСвойств); Запрос.УстановитьПараметр("ЭтоОсновнойЯзык", ТекущийЯзык() = Метаданные.ОсновнойЯзык); Запрос.УстановитьПараметр("КодЯзыка", ТекущийЯзык().КодЯзыка); Запрос.Текст = "ВЫБРАТЬ | НаборыСвойств.Набор КАК Набор, | НаборыСвойств.ПорядокНабора КАК ПорядокНабора |ПОМЕСТИТЬ НаборыСвойств |ИЗ | &НаборыСвойств КАК НаборыСвойств |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ РАЗРЕШЕННЫЕ | НаборыСвойств.Набор КАК Набор, | НаборыСвойств.ПорядокНабора КАК ПорядокНабора, | СвойстваНаборов.Свойство КАК Свойство, | СвойстваНаборов.ПометкаУдаления КАК ПометкаУдаления, | СвойстваНаборов.НомерСтроки КАК ПорядокСвойства |ПОМЕСТИТЬ СвойстваНаборов |ИЗ | НаборыСвойств КАК НаборыСвойств | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.НаборыДополнительныхРеквизитовИСведений.ДополнительныеРеквизиты КАК СвойстваНаборов | ПО (СвойстваНаборов.Ссылка = НаборыСвойств.Набор) | ВНУТРЕННЕЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК Свойства | ПО (СвойстваНаборов.Свойство = Свойства.Ссылка) |ГДЕ | НЕ СвойстваНаборов.ПометкаУдаления | И НЕ Свойства.ПометкаУдаления |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ РАЗРЕШЕННЫЕ | Свойства.Ссылка КАК Свойство |ПОМЕСТИТЬ ЗаполненныеСвойства |ИЗ | ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК Свойства |ГДЕ | Свойства.Ссылка В(&Свойства) |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ | СвойстваНаборов.Набор КАК Набор, | СвойстваНаборов.ПорядокНабора КАК ПорядокНабора, | СвойстваНаборов.Свойство КАК Свойство, | СвойстваНаборов.ПорядокСвойства КАК ПорядокСвойства, | СвойстваНаборов.ПометкаУдаления КАК Удалено |ПОМЕСТИТЬ ВсеСвойства |ИЗ | СвойстваНаборов КАК СвойстваНаборов | |ОБЪЕДИНИТЬ ВСЕ | |ВЫБРАТЬ | ЗНАЧЕНИЕ(Справочник.НаборыДополнительныхРеквизитовИСведений.ПустаяСсылка), | 0, | ЗаполненныеСвойства.Свойство, | 0, | ИСТИНА |ИЗ | ЗаполненныеСвойства КАК ЗаполненныеСвойства | ЛЕВОЕ СОЕДИНЕНИЕ СвойстваНаборов КАК СвойстваНаборов | ПО ЗаполненныеСвойства.Свойство = СвойстваНаборов.Свойство |ГДЕ | СвойстваНаборов.Свойство ЕСТЬ NULL |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ РАЗРЕШЕННЫЕ | ВсеСвойства.Набор КАК Набор, | ВсеСвойства.Свойство КАК Свойство, | ДополнительныеРеквизитыИСведения.ВладелецДополнительныхЗначений КАК ВладелецДополнительныхЗначений, | ДополнительныеРеквизитыИСведения.ЗаполнятьОбязательно КАК ЗаполнятьОбязательно, | ВЫБОР | КОГДА &ЭтоОсновнойЯзык | ТОГДА ДополнительныеРеквизитыИСведения.Заголовок | ИНАЧЕ ВЫРАЗИТЬ(ЕСТЬNULL(СвойстваПредставления.Заголовок, ДополнительныеРеквизитыИСведения.Заголовок) КАК СТРОКА(150)) | КОНЕЦ КАК Наименование, | ДополнительныеРеквизитыИСведения.ТипЗначения КАК ТипЗначения, | ДополнительныеРеквизитыИСведения.ФорматСвойства КАК ФорматСвойства, | ДополнительныеРеквизитыИСведения.МногострочноеПолеВвода КАК МногострочноеПолеВвода, | ВсеСвойства.Удалено КАК Удалено, | ДополнительныеРеквизитыИСведения.Доступен КАК Доступен, | ДополнительныеРеквизитыИСведения.Виден КАК Виден, | ВЫБОР | КОГДА &ЭтоОсновнойЯзык | ТОГДА ДополнительныеРеквизитыИСведения.Подсказка | ИНАЧЕ ВЫРАЗИТЬ(ЕСТЬNULL(СвойстваПредставления.Подсказка, ДополнительныеРеквизитыИСведения.Подсказка) КАК СТРОКА(150)) | КОНЕЦ КАК Подсказка, | ДополнительныеРеквизитыИСведения.ВыводитьВВидеГиперссылки КАК ВыводитьВВидеГиперссылки, | ДополнительныеРеквизитыИСведения.ЗависимостиДополнительныхРеквизитов.( | ЗависимоеСвойство КАК ЗависимоеСвойство, | Реквизит КАК Реквизит, | Условие КАК Условие, | Значение КАК Значение, | НаборСвойств КАК НаборСвойств | ) КАК ЗависимостиДополнительныхРеквизитов |ИЗ | ВсеСвойства КАК ВсеСвойства | ВНУТРЕННЕЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения | ПО ВсеСвойства.Свойство = ДополнительныеРеквизитыИСведения.Ссылка | ЛЕВОЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения.Представления КАК СвойстваПредставления | ПО (СвойстваПредставления.Ссылка = ДополнительныеРеквизитыИСведения.Ссылка) | И (СвойстваПредставления.КодЯзыка = &КодЯзыка) | |УПОРЯДОЧИТЬ ПО | Удалено, | ВсеСвойства.ПорядокНабора, | ВсеСвойства.ПорядокСвойства"; Если ЭтоДополнительноеСведение Тогда Запрос.Текст = СтрЗаменить( Запрос.Текст, "Справочник.НаборыДополнительныхРеквизитовИСведений.ДополнительныеРеквизиты", "Справочник.НаборыДополнительныхРеквизитовИСведений.ДополнительныеСведения"); КонецЕсли; ОписаниеСвойств = Запрос.Выполнить().Выгрузить(); ОписаниеСвойств.Индексы.Добавить("Свойство"); ОписаниеСвойств.Колонки.Добавить("Значение"); // Удаление дублей свойств в нижестоящих наборах свойств. Если Наборы.Количество() > 1 Тогда Индекс = ОписаниеСвойств.Количество()-1; Пока Индекс >= 0 Цикл Строка = ОписаниеСвойств[Индекс]; НайденнаяСтрока = ОписаниеСвойств.Найти(Строка.Свойство, "Свойство"); Если НайденнаяСтрока <> Неопределено И НайденнаяСтрока <> Строка Тогда ОписаниеСвойств.Удалить(Индекс); КонецЕсли; Индекс = Индекс-1; КонецЦикла; КонецЕсли; // > Неопределено Тогда // > 

Работа в примерах была осуществлена с версией БСП: 3.1.2.245

Условие в запросе 1с как допреквизит

grafic1.jpg
Видеоинструкция к этой статье https://youtu.be/f9Q8398SjE4 В 1С Управление Нашей Фирмой есть возможность создавать дополнительные реквизиты — поля и справочники для ввода данных без программиста. Ссылки на добавление реквизитов есть во многих карточках и документах — карточка контрагента, карточка номенклатуры, заказ покупателя и т. п. Дополнительные реквизиты могут использоваться в вспомогательных целях, таких как переменные в формулах динамических спецификаций. Возможность использовать доп. реквизиты в 1С Управление Нашей Фирмой включается при установке программы, но если у вас эта функция отсутствует, то включить ее можно в разделе «Настройки» по ссылке «Общие настройки» Рис 1. Включение модуля Дополнительных реквизитов в 1С Управление Нашей Фирмой
Рис 1. Включение модуля Дополнительных реквизитов в 1С Управление Нашей Фирмой Для просмотра дополнительных реквизитов, а также для их создания и редактирования, необходимо в «Общих настройках» пройти по ссылке «Дополнительные реквизиты». Рис 2. Журнал Дополнительные реквизиты в 1С Управление Нашей Фирмой
Рис 2. Журнал Дополнительные реквизиты в 1С Управление Нашей Фирмой Журнал состоит из шапки с управляющими кнопками - «Добавить», «Копировать» и «Вставить», а также двух окон - в левом окне находится иерархический список групп (папок) реквизитов и в правом окне показываются дополнительные реквизиты, которые относятся в выделенной папке. Для добавления реквизита необходимо нажать на кнопку «Добавить» и выбрать один из двух вариантов - «Новый» и «Из другого набора» Рис 3. Кнопка добавить в журнале Дополнительные реквизиты в 1С Управление Нашей Фирмой
Рис 3. Кнопка «Добавить» в журнале Дополнительные реквизиты в 1С Управление Нашей Фирмой
Начнем обзор с создания нового реквизита.

1. Создание нового реквизита

Рис 4. Карточка создания Дополнительного реквизита в 1С Управление Нашей Фирмой

Для создания нового реквизита в журнале «Дополнительные реквизиты» нажимаем кнопку «Добавить» и выбираем вариант «Новый». Откроется карточка создания Дополнительного реквизита.
Рис 4. Карточка создания Дополнительного реквизита в 1С Управление Нашей Фирмой

Поле «Наименование»

В первую очередь необходимо заполнить поле «Наименование» - наименование реквизита должно четко его идентифицировать, так как на его основании будет заполнено поле «Идентификатор для формул» и поле «Имя» в блоке «Для разработчиков», которое используется для программного обращения к данному реквизиту.

Поле «Тип значения»

Рис 5. Карточка выбора Типов значений карточки Дополнительного реквизита в 1С Управление Нашей Фирмой

В строке «Тип значения» необходимо выбрать значение из раскрывающегося списка, который открывается нажатием на кнопку с тремя точками в правой части строки.
Рис 5. Карточка выбора Типов значений карточки Дополнительного реквизита в 1С Управление Нашей Фирмой Часть элементов справочника «Типы значений» понятна большинству пользователей - Дата, Валюта и т. п., а часть значений будет понятна специалистам или опытным пользователям - рассмотрим эти значения подробно с примерами использования доп. реквизитов в карточке номенклатуры.

Типы значений дополнительных реквизитов в 1С: Управление Нашей Фирмой
1)Булево

Булево — имеет только 2 значения: да/нет, истина/ложь и т. п. Рис 6. Вариант карточки Дополнительного реквизита при выборе типа значений Булево в 1С Управление Нашей Фирмой
Рис 6. Вариант карточки Дополнительного реквизита при выборе типа значений Булево в 1С Управление Нашей Фирмой В карточке Номенклатуры этот тип данных может выглядеть как Чек-бокс с галочкой. Рис 7. Вариант карточки Номенклатуры при выборе типа значений Булево в 1С Управление Нашей Фирмой
Рис 7. Вариант карточки Номенклатуры при выборе типа значений Булево в 1С Управление Нашей Фирмой.
Мы можем изменить формат отображения нажав на ссылку «Формат по умолчанию» в карточке доп. реквизита справа от поля «Тип значения» Рис 8. Конструктор форматной строки при выборе типа значений Булево в 1С Управление Нашей Фирмой
Рис 8. Конструктор форматной строки при выборе типа значений Булево в 1С Управление Нашей Фирмой.
Клик по ссылке откроет форму «Конструктор форматной строки». В ней нам нужен список из двух значений «Представление значения булево Ложь» и «Представление значения булево Истина» - если галочки перед строками снять, то останется первый вариант с чек-боксом. В поле со значениями мы можем выбрать из трех вариантов Ложь/Истина, Да/Нет, Выключено/Включено или ввести собственное значение как в примере (см. Рис. 11). В результате изменения формата в карточке номенклатуры этот реквизит будет выглядеть как текстовое поле с выбором значения, но на выбор будет выводиться только два значения. Рис 9. Дополнительный реквизит с типом Булево с собственными значениями в карточке номенклатуры в 1С Управление Нашей Фирмой Рис 9. Дополнительный реквизит с типом Булево с собственными значениями в карточке номенклатуры в 1С Управление Нашей Фирмой.

2)Строка

Строка - самый простой тип значений, который позволяет вводить любой набор символов. К строке не привязан справочник значений, поэтому в ней нет повторного выбора ранее введенной информации. При выборе Типа значения в форме «Редактирование типа данных» в нижней части формы в зависимости от типа данных появляются дополнительные настройки. Рис 10. Настройки отображения данных дополнительных реквизитов в 1С Управление Нашей Фирмой
Рис 10. Настройки отображения данных дополнительных реквизитов в 1С Управление Нашей Фирмой. В типе значений «Строка» в нижней части расположены настройки длины строки: Длина — количество символов, Вариант изменения длины строки — «Переменная» (в зависимости от количества введенных символов) и «Фиксированная», а также чек-бокс для галочки «Неограниченная» - снимает все ограничения по количеству вводимых символов. После выбора этого Типа значения в карточке Дополнительного реквизита появятся три дополнительных варианта выбора отображения реквизита — «Однострочное поле ввода», «Многострочное поле ввода» - при выборе данного варианта активируется параметр «Количество строк», который позволяет ограничить количество строк ввода. Рис 11. Дополнительные параметры Дополнительных реквизитов с типом Строка в 1С Управление Нашей Фирмой
Рис 11. Дополнительные параметры Дополнительных реквизитов с типом Строка в 1С Управление Нашей Фирмой.

3)Дополнительное значение

Дополнительное значение — раскрывающийся список, в котором значения могут быть внесены заранее или добавляться в процессе работы. Рис 12. Создание Дополнительного реквизита с типом значения Дополнительное в 1С Управление Нашей Фирмой
Рис 12. Создание Дополнительного реквизита с типом значения Дополнительное в 1С Управление Нашей Фирмой. Галочка «Выводить в виде гиперссылки» позволяет отображать этот тип значений в документе в двух вариантах: без галочки — как раскрывающийся список, а с галочкой — как гиперссылка Вариант без галочки: Рис 13. Дополнительный реквизит с типом значения Дополнительное в 1С Управление Нашей Фирмой
Рис 13. Дополнительный реквизит с типом значения Дополнительное в карточке номенклатуры в 1С Управление Нашей Фирмой. Для выбора значения нажимаем на стрелочку в правой части поля и появляется форма значения, в которой переходим по ссылке «Показать все» или «+(создать)». При установленной галочке значение выводится, как ссылка, а для его изменения необходимо нажать на карандаш (справа от строки). Рис 14. Гиперссылка дополнительного реквизита в карточке номенклатуры в 1С Управление Нашей Фирмой
Рис 14. Гиперссылка дополнительного реквизита в карточке номенклатуры в 1С Управление Нашей Фирмой. Ниже выбора варианта отображения, располагается табличная форма с двумя вкладками - «Главное» и «Значения». Во вкладке «Главное» заполняем поля по необходимости - более подробно рассмотрим поля ниже. Во вкладке «Значения» содержится список значений, присвоенных данному реквизиту. Рис 15. Вкладка Значения в карточке дополнительного реквизита в 1С Управление Нашей Фирмой
Рис 15. Вкладка «Значения» в карточке дополнительного реквизита в 1С Управление Нашей Фирмой. Значения можно ввести в этой вкладке с помощью кнопки «Создать» или после в процессе работы, как показано на Рис. 13. Кнопка «Еще» раскрывает список дополнительных действий по управлению списком. Рис 16. Список действий кнопки Еще вкладки Значения карточки дополнительного реквизита в 1С Управление Нашей Фирмой.
Рис 16. Список действий кнопки «Еще» во вкладки «Значения» карточки дополнительного реквизита в 1С Управление Нашей Фирмой. Под полем списка значений располагается чек-бокс «Значения дополнительно характеризуются весовым коэффициентом» - после установки этой галочки каждому значению можно добавить числовое значение, которое позволяет дополнительно сортировать значения в отчетах или при выборе, также можно его использовать в других целях. В списке значений добавится колонка «Весовой коэффициент». Рис 17. Весовые коэффициенты значений в карточке дополнительного реквизита в 1С Управление Нашей Фирмой.
Рис 17. Весовые коэффициенты значений в карточке дополнительного реквизита в 1С Управление Нашей Фирмой. Значения можно сгруппировать — кнопка «Создать группу» позволяет создавать группы (папки) значений.

4)Число

Рис 18. Настройки дополнительного реквизита при выборе типа значений в 1С Управление Нашей Фирмой.

Этот тип значений ограничен только числовыми значениями. В настройке отображения этого реквизита при его выборе программа выдает два поля: «Длина» - количество вводимых символов, «Точность» - количество символов после запятой, а также чек-бокс для галочки «Неотрицательное» - установленная галочка не дает ввести отрицательное число.
Рис 18. Настройки дополнительного реквизита при выборе типа значений в 1С Управление Нашей Фирмой. Остальные Типы значений и их настройка более понятны пользователям и не имеют дополнительных настроек поэтому не будем их рассматривать. Рассмотрим остальные элементы карточки «Дополнительный реквизит» общие для всех типов.

5)Составной тип данных

Составной тип данных находится в верней части формы выбора. Установка галочки позволяет создать поле, при нажатии на которое программа попросит у пользователя самостоятельно выбрать тип вводимых данных. После установки галочки в чек-боксе «Составной тип данных» в списке появляется возможность выбора нескольких значений — например: В заказе покупателя вы хотите отобразить Агента, человека, который нашел данный заказ -сторонний человек или сотрудник предприятия. Создаем дополнительный реквизит с названием «Агент». А при выборе типа значений устанавливаем галочки: «Составной тип данных», «Контрагент», «Сотрудник». Рис 19. Составной тип данных дополнительного реквизита в 1С Управление Нашей Фирмой
Рис 19. Составной тип данных дополнительного реквизита в 1С Управление Нашей Фирмой. В Заказе покупателя находим созданный реквизит «Агент» и нажимаем на три точки в правой части поля и, в открывшейся форме, нажимаем на нужный тип данных — Сотрудник или Контрагент Рис 20. Поле с составным дополнительным реквизитом в 1С Управление Нашей Фирмой
Рис 20. Поле с составным дополнительным реквизитом в 1С Управление Нашей Фирмой. Выбор поля дает доступ к нужному справочнику «Контрагенты» или «Сотрудники». В конце месяца можно отсортировать заказы по контрагентам и сотрудникам, начислить комиссионное вознаграждение контрагентам или премию сотрудникам.

Ссылка «Виден»
  • «Реквизит» - двойной клик на ячейку активирует ее, а клик на кнопку с тремя точками в правой части ячейки откроет дополнительную форму «Выбор реквизита» со списком доступных реквизитов, в котором кроме реквизитов программы есть дополнительные реквизиты, введенные нами. Выбираем доп. реквизит «Дополнительный цвет».

Рис 21. Настройка условий видимости дополнительного реквизита в 1С Управление Нашей Фирмой

Рис 21. Настройка условий видимости дополнительного реквизита в 1С Управление Нашей Фирмой.

  • «Вид сравнения» - двойной клик откроет список выбора вида сравнения — равно, не равно, заполнено, не заполнено и т. п.
  • «Значение» - двойной клик откроет список значений выбранного реквизита, выбираем кликом нужное значение

В примере у нас получилось условие: Если в реквизите «Дополнительный цвет» установлена галочка, то реквизит «дополнительная гамма цветов» становится виден.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *