Почему pycharm не видит модули
Перейти к содержимому

Почему pycharm не видит модули

  • автор:

pycharm не видит стандартные модули

Проблема: после установки новой версии python и удаления старой (3.4) PyCharm отказывается видеть стандартные модули python.

Вот список замеченных проблем в редакторе:

  • Не получается импортировать модули. Например sys и os . Их подчеркивает красным.
  • print() не работает — подчеркивает красным.
  • Нет автодополнения

При этом команда run или python console , из того же PyCharm, запускаются, как надо, импортируется, что надо, все ок. А вот в редакторе проблема.

Интерпретатор указан, а куда еще смотреть не знаю, нужна помощь.

Почему pyCharm не видит библиотеки при импорте, хоть установка прошла успешно?

Не понимаю, почему pycharm не видит библиотеки при импорте, хоть их установка через консоль проходит успешно. Допустим, я устанавливаю библиотеку speech_recognition через терминал(используя pip), установка проходит успешно, но при попытке импортировать библиотеку, появляется ошибка: «ModuleNotFoundError: No module named ‘speech_recognition'». После я устанавливаю эту библиотеку через менеджер пакетов, теперь ее видно, но не хватает библиотеки pyAudio. При установке pyAudio через консоль, библиотеки также не видно, а при установке pyAudio через менеджер появляется ошибка, связанная именно с самим пакетом. И по такой же схеме со всеми библиотеками, только названия меняются, поэтому не могу с ними работать, что мне делать?

  • Вопрос задан более года назад
  • 14197 просмотров

1 комментарий

Простой 1 комментарий

PyCharm сломался и не видит библиотеку

Author24 — интернет-сервис помощи студентам

Здравствуйте!
PyСharm не видит стандартную библиотеку turtle — чеперашка для изучения питона. (OS Linux Mint)
На другом компьютере (Ubuntu/PyCharm) код работает без ошибок.
На этом же запускал в Spyder и через терминал: python3 1.py — работает.
Сломан именно PyCharm, установленный из менеджера приложений.
Если удалить PyCharm установленный из менеджера приложений и установить с сайта JetBrains, то код тоже работает.
Заметил так же, что PyCharm с JetBrains работает с python3.5 (как в системе), а PyCharm из менеджера приложений с python3.9.

Что пытался:
— выбрать системный интерпретатор : /usr/bin/python3 (по какой-то причине по указанному адресу появляется и 3.9 версия)
— переустановить PyCharm из менеджера приложений
— сбрасывать File > Manage IDE Settings > Restore Default Settings
Не помогает ничего

1 2 3 4 5 6 7 8 9 10 11 12
import turtle turtle.shape('turtle') turtle.forward(50) turtle.left(90) turtle.forward(50) turtle.left(90) turtle.forward(50) turtle.right(90) turtle.forward(50) turtle.right(90) turtle.forward(50)

Прошу помочь разобраться в чем же причина такого капризного поведения PyCharm
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
Ответы с готовыми решениями:

Сломался дебаггер в PyCharm
Приветствую! После установки Python 3.10, PyCharm просит установить Microsoft Visual C++ 14.0.

PyCharm сломался и не выполняет код
Здравствуйте. У меня сломался PyCharm и не выполняет код. Когда ввожу какую-либо команду, да даже.

Добавить установленную библиотеку в Pycharm
Здравствуйте. Подскажите пожалуйста. Установил библиотеку через pip. Но Pycharm ее не видит. Как.

В Pycharm не получается установить библиотеку Beautifulsoup
Не могу установить ни одну библиотеку. Я захожу в settings нажимаю Python interpreter и там дальше.

Pycharm видит все модули даже «мои» через modules, но дело в том, что при import. не видит мой модуль
но проблема в том, что при import. или from. pycharm не видит мой собственный модуль. Во всех.

Эксперт Python

5417 / 3841 / 1214
Регистрация: 28.10.2013
Сообщений: 9,554
Записей в блоге: 1
Регистрация: 05.11.2012
Сообщений: 108

ЦитатаСообщение от Garry Galler Посмотреть сообщение

https://stackoverflow.com/ques. med-turtle

Разумеется я гуглил и находил этот пост. Автор же написал, что проблему решил только установкой программы с JetBrains, то я и описывал в посте. Предложенный вариант другим пользователем не работает. Так как модуль turtle находится совершенно другой, связанный с HTTP протоколом, а не с нужной черепашкой. Об этом автор той темы тоже указал.

Я не хочу ставить версию с сайта JetBrains, так как она просто распакованная в папочке, без установки в систему. Мне именно установить нужно программу

Добавлено через 1 час 15 минут
Это вообще очень странная проблема.
Из консоли я могу запустить программу — работает. Я могу создать вируальное окружение и его активировать — запустить программу — работает.
Открываю в пайчарм этот же файл — не работает. Выбираю интерпретатор, что лежит в созданном мной окружении — запускаю — не работает.
Установить через pip модуль turtle или через установку пакетов в GUI я тоже не могу. Потому что там находится какой-то другой turtle, связанный с HTTP, а это совсем не то.

Не устанавливаются модули в PyCharm

Author24 — интернет-сервис помощи студентам

. Установив попутно VS C++ 14.0 Builder, без него не хотел устанавливаться
1.2 После этого пытаюсь подтянуть в проект через Settings — > Project — > Project Interpreter -> «+». Выдает ошибку «error: command ‘C:\\Program Files (x86)\\Microsoft Visual Studio 14.0\\VC\\BIN\\x86_amd64\\cl.exe’ failed with exit status 2»

Кликните здесь для просмотра всего текста

Collecting PyQt5
Using cached https://files.pythonhosted.org. _amd64.whl
Collecting PyQt5-sip=12.7 (from PyQt5)
Using cached https://files.pythonhosted.org. 7.2.tar.gz
Installing build dependencies: started
Installing build dependencies: finished with status ‘done’
Getting requirements to build wheel: started
Getting requirements to build wheel: finished with status ‘done’
Preparing wheel metadata: started
Preparing wheel metadata: finished with status ‘done’
Building wheels for collected packages: PyQt5-sip
Building wheel for PyQt5-sip (PEP 517): started
Building wheel for PyQt5-sip (PEP 517): finished with status ‘error’
Complete output from command D:\Coding\GraficPyQTProjects\venv\Scripts\python.exe D:\Coding\GraficPyQTProjects\venv\lib\site-packages\pip-19.0.3-py3.8.egg\pip\_vendor\pep517\_in_process.py build_wheel C:\Users\Fil\AppData\Local\Temp\tmpgiaufzj8:
running bdist_wheel
running build
running build_ext
building ‘PyQt5.sip’ extension
creating build
creating build\temp.win-amd64-3.8
creating build\temp.win-amd64-3.8\Release
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\x86_amd64\cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MD -ID:\Coding\GraficPyQTProjects\venv\include -IC:\Users\Fil\AppData\Local\Programs\Python\Python38\include -IC:\Users\Fil\AppData\Local\Programs\Python\Python38\include «-IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE» «-IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\ATLMFC\INCLUDE» «-IC:\Program Files (x86)\Windows Kits\10\include\10.0.10240.0\ucrt» /Tcapiversions.c /Fobuild\temp.win-amd64-3.8\Release\apiversions.obj
apiversions.c
c:\users\fil\appdata\local\programs\python\python38\include\pyconfig.h(206): fatal error C1083: ЌҐ г¤ Ґвбп ®вЄалвм д ©« ўЄ«о祭ЁҐ: basetsd.h: No such file or directory,
error: command ‘C:\\Program Files (x86)\\Microsoft Visual Studio 14.0\\VC\\BIN\\x86_amd64\\cl.exe’ failed with exit status 2

—————————————-
Running setup.py clean for PyQt5-sip
Failed to build PyQt5-sip

Failed building wheel for PyQt5-sip
Could not build wheels for PyQt5-sip which use PEP 517 and cannot be installed directly

2. Не устанавливается модуль PyGame. Причем в другой проект несколько месяцев назад он подтянулся и там работает нормально, а в новый подтягиваться не хочет — выдает «EOFError: EOF when reading a line»

Кликните здесь для просмотра всего текста

Collecting pygame
Using cached https://files.pythonhosted.org. 9.6.tar.gz
Complete output from command python setup.py egg_info:

WARNING, No «Setup» File Exists, Running «buildconfig/config.py»
Using WINDOWS configuration.

Download prebuilts to «prebuilt_downloads» and copy to «./prebuilt-x64»? [Y/n]Traceback (most recent call last):
File «», line 1, in
File «C:\Users\Fil\AppData\Local\Temp\pycharm-packaging\pygame\setup.py», line 194, in
buildconfig.config.main(AUTO_CONFIG)
File «C:\Users\Fil\AppData\Local\Temp\pycharm-packaging\pygame\buildconfig\config.py», line 210, in main
deps = CFG.main(**kwds)
File «C:\Users\Fil\AppData\Local\Temp\pycharm-packaging\pygame\buildconfig\config_win.py», line 576, in main
and download_win_prebuilt.ask(**download_kwargs):
File «C:\Users\Fil\AppData\Local\Temp\pycharm-packaging\pygame\buildconfig\download_win_prebuilt.py», line 302, in ask
reply = raw_input(
EOFError: EOF when reading a line

Command «python setup.py egg_info» failed with error code 1 in C:\Users\Fil\AppData\Local\Temp\pycharm-packaging\pygame\

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *