Что такое булево в 1с
Перейти к содержимому

Что такое булево в 1с

  • автор:

Что такое булево в 1с

Значение Булево 1С — это значение Истина или Ложь. В числовом выражении Ложь это ноль, а Истина — число больше нуля (обычно единица).

Выражение (операция) Булево 1С — это математическое выражение, результатов которого является значение типа Булево 1С, например:
a = 0+1;
b = 2-1;
x = (a = b);
//x = Истина

Далее — подробнее о условных операциях 1С, значениях и выражениях булево 1С.

Условная операция 1С ЕСЛИ выглядит следующим образом:
Если ОПЕРАЦИЯ-БУЛЕВО Тогда
//действия1…
ИначеЕсли ОПЕРАЦИЯ-БУЛЕВО Тогда
//действия2…
Иначе
//действия3…
КонецЕсли;

Булево 1С — это результат вычисления со значениями Истина или Ложь, например:
Массив1 = Новый СписокЗначений();
Если Массив1.Количество() > 0 Тогда
//действия…
КонецЕсли;

//другой вариант, полностью аналогичный
Если НЕ Массив1.Количество() = 0 Тогда
//действия…
КонецЕсли;

Многие функции/методы объектов возвращают успешность выполнения операции как булево 1С, например:
Запрос = Новый Запрос();
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
//действия…
КонецЕсли;

В условной операции 1С можно объединять несколько условий с использованием И и ИЛИ:
Массив1 = Новый СписокЗначений();
Если (Массив1.Количество() > 0 и Массив1.Количество() 100 Тогда
//действия…
КонецЕсли;

Условия булево 1С можно использовать непосредственно в коде программы:
Переменная1 = 5;
флгРезультат = (Переменная1 = 2 + 3); //флгРезультат будет равен ИСТИНА

В условной операции 1С оператор ЕСЛИ ИНАЧЕ ТОГДА можно заменить более кратким выражением. Следующие два варианта равны:

Только зарегистрированные пользователи VIP группы могут видеть этот контент.

У реквизитов объектов (справочников, документов и т.п.) есть возможность установить тип булево 1С. Также можно создать переменную булево 1С, например:
флгВыполнено = Истина;

Далее, в условиях ЕСЛИ, можно писать равнозначно двумя способами:
//вариант 1
Если флгВыполнено = Истина Тогда
//делаем что-то
КонецЕсли;

//вариант 2
Если флгВыполнено Тогда
//делаем что-то
КонецЕсли;

Второй вариант таит в себе следующую «неприятность»:

Только зарегистрированные пользователи VIP группы могут видеть этот контент.

Проголосовать за этот пост:

Примитивный тип Булево

Многие, кто только начинает изучать программирование, впервые сталкиваются с новым для себя примитивным типом булево. Еще его по-другому называют логический тип. Данный тип назван в честь английского математика Джорджа Буля, который изучал вопросы математической логики.

Прежде чем начать изучать этот примитивный тип, узнаем вообще, что такое булевы или логические выражения.

Булевы выражения это что-то типа вопроса, на который должен быть однозначные ответ или да, или нет.

Так же могу и быть более сложные вопросы:

Кнопка нажата – да;

Кнопка нажата – нет;

Булевы выражения используются во всех условных переходах:

Если Булево выражение1> тогда //операторы ИначеЕсли БулевоВыражение2> тогда //операторы КонецЕсли; 

В языке программирования 1С переменную с примитивным типом Булево можно задать явно:

А = Истина; Б = Ложь; 

Где Истина и Ложь единственные значения, которые может принимать примитивный тип Булево.

Истина – значит, что какое-то утверждение соответствует действительности (Ответ — Да).

Ложь – значить, что какое-то утверждение, наоборот, не соответствует действительности (Ответ –Нет).

Так же переменные с типом булево могут быть заданы с помощью какого-либо логического выражения.
Например:

А = 5  7; Б = 6 > 9; 

В этом случае, в переменой А будет значение Истина, а в переменной типа Б – ложь;

В языке программирования 1С над переменными типа булево можно осуществлять различные операции.

А = 5  7; Б = 6 > 9; В = А И Б; С = А ИЛИ Б; Д = Не А; 

Всего их три – И, ИЛИ и НЕ.

Понять функциональность этих операций помогут следующие таблицы

А Б
Истина Ложь
Ложь Истина
С = А И Б А Б
Истина Истина Истина
Ложь Ложь Истина
Ложь Истина Ложь
Ложь Ложь Ложь
С = А ИЛИ Б А Б
Истина Истина Истина
Истина Ложь Истина
Истина Истина Ложь
Ложь Ложь Ложь

А можно ли выполнять данные операции подряд?

Да можно, данные операции будут выполняться слева направо. И иметь следующий уровень старшинства:

Первый: в первую очередь выполняются операции в скобках

Второй: Операция НЕ

Третий: Операция И

Четвертый: Операция ИЛИ.

Чтобы не путаться в операциях, я советую Вам использовать скобки, где только возможно.

А = Ложь; Б = Истина; С = Ложь; Д = А и С или Б; 

В данном случае сначала будет работать операция И между А и С.

Смотрим таблицу А – Ложь, С – Ложь, результат А И С будет Ложь.

Следующим шагом будет выполнение операции ИЛИ между Ложью (Результат предыдущей операции) и значением Б, которое Истина.

Результат будет Истина.

А если нам надо, чтобы прошла сначала операция ИЛИ между С и Б, а потом только операция И между А и тем, что получилось, то для этого необходимо использовать скобки.

А = Ложь; Б = Истина; С = Ложь; Д = А и (С или Б); 

Результат будет диаметрально противоположный. Почему? Сейчас разберем. Благодаря скобкам сначала выполняется операция и между С и Б, т.к. С — Ложь, а Б – Истина, результат будет Истина. Потом между значением А (которое Ложь) и значением Истина (результатом предыдущей операции) выполняется операция И. Результат будет Ложь.

Многие начинающие программисты не совсем до конца понимают принципы взаимодействия между переменными типа Булево. Помочь в этом сможет только практика. А практики с переменными типа Булево достаточно в моем задачнике к книге «Программировать в 1С за 11 шагов»

Изучайте основы конфигурирования в 1С и учитесь программировать в «1С: Предприятии» с помощью моих книг: «Программировать в 1С за 11 шагов» и «Основы разработки в 1С: Такси»

Изучайте программирование в 1С в месте с моей книги «Программировать в 1С за 11 шагов»

  1. Книга написана понятным и простым языком — для новичка.
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Научитесь понимать архитектуру 1С;
  4. Станете писать код на языке 1С;
  5. Освоите основные приемы программирования;
  6. Закрепите полученные знания при помощи задачника;

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu


Если Вам помог этот урок решить какую-нибудь проблему, понравился или оказался полезен, то Вы можете поддержать мой проект, перечислив любую сумму:

можно оплатить вручную:

Яндекс.Деньги — 410012882996301
Web Money — R955262494655

Вступайте в мои группы:

2 Replies to “Примитивный тип Булево”

Sergey :

Что-то вы напутали. Операция (А И В) будет равна Истина, только если ОБА операнда равны Истина.
Операция (А ИЛИ В) равна Истина, если ХОТЯ БЫ ОДИН из операндов равен Истина.

Что такое булево в 1с

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Владимир Милькин

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

1С Как проверить значение элемента формы с типом булево

Сегодня поговорим про примитивный тип булево и про то как можно проверить значение подобного элемента на форме. У булева может быть только два значения «Ложь» или «Истина», на форме он обычно выглядит как флажок (флаговая кнопка, чекбокс, галочка) данный элемент все называют по разному. Проверить его значение можно по разному, сегодня рассмотрим один из более популярных и используемых вариантом, будем проверять установлен флажок или нет, и дополнительно в зависимости от варианта отображать другой элемент формы.

Проверка значения примитивного типа Булево

Давайте для примера сделаем вот такую форму, с её помощью мы будем регистрировать почту. На форме будет два элемента с типом Булево это «Входящая» и «Исходящая». Суть в том что, если письмо входящие нужно заполнить поле «Отправитель» а если исходящие тогда «Получатель».

Отображать на форме сразу два этих поля не совсем правильно, мы сделаем так, если булево «Входящая» будет отмечено то автоматически на форме будет отображаться поле «Отправитель», соответственно если будет отмечено булево «Исходящая» будет появляться поле «Получатель».

Таким образом мы будем проверять значение элемента формы с типом булево.

1С Тип Булево

Думаю как сделать реквизит с типом булево вы уже знаете если нет то в свойствах реквизита в поле «Тип» нужно выбрать «Булево» и все.

1С Как проверить значение элемента формы типа булево

Дальше отключим видимость тех реквизитов которые должны появляется автоматически «Отправитель» и «Получатель».

Проверка значения примитивного типа Булево

И для каждого реквизита с типом булево «Входящая» и «Исходящая» создадим событие «При изменении».

1С проверить тип булево

Остается написать небольшое условие которые будет проверять значение булева и в зависимости от него «Истина» или «Ложь» отображать дополнительный реквизит на форме. Т.е если флажок стоить (это истина) нужно отображать соответствующий элемент, а если флажка нет (это ложь) то и элемент не нужно отображать.

Как проверить значение булева

Сохраняем и проверяем что получилось, отмечаем первый реквизит с типом булево «Входящая».

1С тип булево

После этого на форме должен появиться элемент «Отправитель».

проверка элемента формы булево

Если выбрать «Исходящая» то должен появиться другой элемент «Получатель».

Как проверить булево

Как вариант можно сделать для проверки отдельную команду (кнопку).

1С как проверить значение булева

Создать для неё вот такую процедуру которая будет проверять значения элементов с типом булево и в зависимости от результата отображать нужный реквизит.

Проверка элемента формы булево

Работать это будет примерно также, выбираем «Входящая» или «Исходящая» и нажимаем «Проверить булева», в результате также будет появляться дополнительный элемент на форме.

1С проверка булева

Вот один из вариантов проверки значения реквизита с типом булева на форме. Как видите все не так и сложно, но если остались вопросы или что-тоне получилось обязательно напишите.

Раздел: 1С Программирование Метки: 1С Тип Булево

1С Тип Булево : 2 комментария

  1. Joshuafluro 11.07.2022 Тема: требуется консультация
    Здравствуйте свяжитесь пожалуйста со мной, если не отвечаю напишите в вотсап
    Телефон: +7(914)422
    Почта: ooo-estet20
  1. admin Автор записи 11.07.2022 Здравствуйте! Пишите сразу на почту admin@sibsisadmin.ru

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *