К какой категории относится функция если
Перейти к содержимому

К какой категории относится функция если

  • автор:

Функция ЕСЛИ — вложенные формулы и типовые ошибки

Excel для Microsoft 365 Excel для Microsoft 365 для Mac Excel для Интернета Excel 2021 Excel 2021 для Mac Excel 2019 Excel 2019 для Mac Excel 2016 Excel 2013 Excel Web App Excel для Windows Phone 10 Еще. Меньше

Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

  • =ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Инструкции IF невероятно надежны и являются основой для многих моделей электронных таблиц, но они также являются первопричиной многих проблем с электронными таблицами. В идеале оператор IF должен применяться к минимальным условиям, таким как Male/Female, Yes/No/Maybe, чтобы назвать несколько, но иногда может потребоваться оценить более сложные сценарии, требующие вложения* более 3 функций IF вместе.

* «Вложенность» означает объединение нескольких функций в одной формуле.

Технические подробности

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

  • =ЕСЛИ(A2>B2;»Превышение бюджета»;»ОК»)
  • =ЕСЛИ(A2=B2;B4-A4;»»)

Имя аргумента

лог_выражение

Условие, которое нужно проверить.

значение_если_истина

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

значение_если_ложь

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Примечания

Excel позволяет использовать до 64 вложенных функций ЕСЛИ, но это вовсе не означает, что так и надо делать. Почему?

  • Нужно очень крепко подумать, чтобы выстроить последовательность из множества операторов ЕСЛИ и обеспечить их правильную отработку по каждому условию на протяжении всей цепочки. Если при вложении вы допустите в формуле малейшую неточность, она может сработать в 75 % случаев, но вернуть непредвиденные результаты в остальных 25 %. К сожалению, шансов отыскать эти 25 % немного.
  • Работа с множественными операторами ЕСЛИ может оказаться чрезвычайно трудоемкой, особенно если вы вернетесь к ним через какое-то время и попробуете разобраться, что пытались сделать вы или, и того хуже, кто-то другой.

Если вы видите, что ваш оператор ЕСЛИ все разрастается, устремляясь в бесконечность, значит вам пора отложить мышь и пересмотреть свою стратегию.

Давайте посмотрим, как правильно создавать операторы с несколькими вложенными функциями ЕСЛИ и как понять, когда пора переходить к другим средствам из арсенала Excel.

Примеры

Ниже приведен пример довольно типичного вложенного оператора ЕСЛИ, предназначенного для преобразования тестовых баллов учащихся в их буквенный эквивалент.

  • =ЕСЛИ(D2>89;»A»;ЕСЛИ(D2>79;»B»;ЕСЛИ(D2>69;»C»;ЕСЛИ(D2>59;»D»;»F»)))) Этот сложный оператор с вложенными функциями ЕСЛИ следует простой логике:
  1. Если тестовых баллов (в ячейке D2) больше 89, учащийся получает оценку A.
  2. Если тестовых баллов больше 79, учащийся получает оценку B.
  3. Если тестовых баллов больше 69, учащийся получает оценку C.
  4. Если тестовых баллов больше 59, учащийся получает оценку D.
  5. В противном случае учащийся получает оценку F.

Этот частный пример относительно безопасен, поскольку взаимосвязь между тестовыми баллами и буквенными оценками вряд ли будет меняться, так что дополнительных изменений не потребуется. Но что если вам потребуется разделить оценки на A+, A и A– (и т. д.)? Теперь ваши четыре условных оператора ЕСЛИ нужно переписать с учетом 12 условий! Вот так будет выглядеть ваша формула:

  • =ЕСЛИ(B2>97;»A+»;ЕСЛИ(B2>93;»A»;ЕСЛИ(B2>89;»A-«;ЕСЛИ(B2>87;»B+»;ЕСЛИ(B2>83;»B»;ЕСЛИ(B2>79;»B-«; ЕСЛИ(B2>77;»C+»;ЕСЛИ(B2>73;»C»;ЕСЛИ(B2>69;»C-«;ЕСЛИ(B2>57;»D+»;ЕСЛИ(B2>53;»D»;ЕСЛИ(B2>49;»D-«;»F»))))))))))))

Он по-прежнему функционально точный и будет работать, как ожидалось, но на запись требуется много времени и больше времени для тестирования, чтобы убедиться, что он делает то, что вы хотите. Еще одна вопиющая проблема заключается в том, что вы должны были ввести оценки и эквивалентные буквы оценки вручную. Каковы шансы на то, что у вас случайно будет опечатка? Теперь представьте, пытаетесь сделать это 64 раза с более сложными условиями! Конечно, это возможно, но вы действительно хотите подвергнуть себя такого рода усилиям и вероятным ошибкам, которые будет очень трудно обнаружить?

Совет: Для каждой функции в Excel обязательно указываются открывающая и закрывающая скобки (). При редактировании Excel попытается помочь вам понять, что куда идет, окрашивая разными цветами части формулы. Например, во время редактирования показанной выше формулы при перемещении курсора за каждую закрывающую скобку «)» тем же цветом будет окрашиваться соответствующая открывающая скобка. Это особенно удобно в сложных вложенных формулах, когда вы пытаетесь выяснить, достаточно ли в них парных скобок.

Дополнительные примеры

Ниже приведен распространенный пример расчета комиссионных за продажу в зависимости от уровней дохода.

  • =ЕСЛИ(C9>15000;20%;ЕСЛИ(C9>12500;17,5%;ЕСЛИ(C9>10000;15%;ЕСЛИ(C9>7500;12,5%;ЕСЛИ(C9>5000;10%;0)))))

Эта формула означает: ЕСЛИ(ячейка C9 больше 15 000, то вернуть 20 %, ЕСЛИ(ячейка C9 больше 12 500, то вернуть 17,5 % и т. д.

Несмотря на то, что это удивительно похоже на предыдущий пример оценок, эта формула является отличным примером того, насколько трудно может быть поддерживать большие инструкции IF. Что нужно сделать, если ваша организация решила добавить новые уровни компенсации и, возможно, даже изменить существующие значения в долларах или процентах? У тебя будет много работы на руках!

Совет: Чтобы сложные формулы было проще читать, вы можете вставить разрывы строк в строке формул. Просто нажмите клавиши ALT+ВВОД перед текстом, который хотите перенести на другую строку.

Перед вами пример сценария для расчета комиссионных с неправильной логикой:

Видите ли вы, что не так? Сравните порядок сравнений доходов с предыдущим примером. В каком направлении это происходит? Правильно, это происходит снизу вверх ($ 5000 до $ 15000), а не наоборот. Но почему это должно быть такое большое дело? Это большое дело, потому что формула не может пройти первую оценку для любого значения более $ 5000. Предположим, что у вас есть $ 12500 в доходе — если отчет вернет 10%, потому что это больше $ 5000, и это остановится на этом. Это может быть невероятно проблематично, так как во многих ситуациях ошибки такого типа не замечены, пока они не окажут негативное влияние. Так зная, что есть некоторые серьезные подводные камни со сложными вложенными утверждениями IF, что вы можете сделать? В большинстве случаев вместо построения сложной формулы с помощью функции IF можно использовать функцию ВПР. Используя функцию ВПР, сначала необходимо создать эталонную таблицу:

Ячейка D2 содержит формулу =ВПР(C2;C5:D17;2;ИСТИНА)

  • =ВПР(C2;C5:D17;2;ИСТИНА)

В этой формуле предлагается найти значение ячейки C2 в диапазоне C5:C17. Если значение найдено, возвращается соответствующее значение из той же строки в столбце D.

Ячейка C9 содержит формулу =ВПР(B9;B2:C6;2;ИСТИНА)

  • =ВПР(B9;B2:C6;2;ИСТИНА)

Эта формула ищет значение ячейки B9 в диапазоне B2:B22. Если значение найдено, возвращается соответствующее значение из той же строки в столбце C.

Примечание: В обеих функциях ВПР в конце формулы используется аргумент ИСТИНА, который означает, что мы хотим найти близкое совпадение. Иначе говоря, будут сопоставляться точные значения в таблице подстановки, а также все значения, попадающие между ними. В этом случае таблицы подстановки нужно сортировать по возрастанию, от меньшего к большему.

VLOOKUP рассматривается здесь гораздо более подробно, но это, безусловно, гораздо проще, чем 12-уровневая сложная вложенная инструкция IF! Есть и другие, менее очевидные, преимущества:

  • Таблицы ссылок функции ВПР открыты и их легко увидеть.
  • Значения в таблицах просто обновлять, и вам не потребуется трогать формулу, если условия изменятся.
  • Если вы не хотите, чтобы люди видели вашу таблицу ссылок или вмешивались в нее, просто поместите ее на другой лист.

Вы знали?

Теперь есть функция УСЛОВИЯ, которая может заменить несколько вложенных операторов ЕСЛИ. Так, в нашем первом примере оценок с 4 вложенными функциями ЕСЛИ:

  • =ЕСЛИ(D2>89;»A»;ЕСЛИ(D2>79;»B»;ЕСЛИ(D2>69;»C»;ЕСЛИ(D2>59;»D»;»F»))))

можно сделать все гораздо проще с помощью одной функции ЕСЛИМН:

  • =ЕСЛИМН(D2>89;»A»;D2>79;»B»;D2>69;»C»;D2>59;»D»;ИСТИНА;»F»)

Функция ЕСЛИМН — просто находка! Благодаря ей вам больше не нужно переживать обо всех этих операторах ЕСЛИ и скобках.

Примечание: Эта функция доступна только при наличии подписки на Microsoft 365. Если вы являетесь подписчиком Microsoft 365, проверьте, установлена ли у вас последняя версия Office.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

ЕСЛИ (функция ЕСЛИ)

Функция ЕСЛИ — одна из самых популярных функций в Excel. Она позволяет выполнять логические сравнения значений и ожидаемых результатов.

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Например, функция =ЕСЛИ(C2=»Да»;1;2) означает следующее: ЕСЛИ(С2=»Да», то вернуть 1, в противном случае вернуть 2).

Ваш браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

  • =ЕСЛИ(A2>B2;»Превышение бюджета»;»ОК»)
  • =ЕСЛИ(A2=B2;B4-A4;»»)

Имя аргумента

лог_выражение (обязательно)

Условие, которое нужно проверить.

значение_если_истина (обязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

значение_если_ложь (необязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Простые примеры функции ЕСЛИ

Ячейка D2 содержит формулу =ЕСЛИ(C2=

  • =ЕСЛИ(C2=»Да»;1;2)

В примере выше ячейка D2 содержит формулу: ЕСЛИ(C2 = Да, то вернуть 1, в противном случае вернуть 2)

Ячейка D2 содержит формулу =ЕСЛИ(C2=1;

  • =ЕСЛИ(C2=1;»Да»;»Нет»)

В этом примере ячейка D2 содержит формулу: ЕСЛИ(C2 = 1, то вернуть текст «Да», в противном случае вернуть текст «Нет»). Как видите, функцию ЕСЛИ можно использовать для сравнения и текста, и значений. А еще с ее помощью можно оценивать ошибки. Вы можете не только проверять, равно ли одно значение другому, возвращая один результат, но и использовать математические операторы и выполнять дополнительные вычисления в зависимости от условий. Для выполнения нескольких сравнений можно использовать несколько вложенных функций ЕСЛИ.

  • =ЕСЛИ(C2>B2;»Превышение бюджета»;»В пределах бюджета»)

В примере выше функция ЕСЛИ в ячейке D2 означает: ЕСЛИ(C2 больше B2, то вернуть текст «Превышение бюджета», в противном случае вернуть текст «В пределах бюджета»)

  • =ЕСЛИ(C2>B2;C2-B2;0)

На рисунке выше мы возвращаем не текст, а результат математического вычисления. Формула в ячейке E2 означает: ЕСЛИ(значение «Фактические» больше значения «Плановые», то вычесть сумму «Плановые» из суммы «Фактические», в противном случае ничего не возвращать).

Ячейка F7 содержит формулу ЕСЛИ(E7=

  • =ЕСЛИ(E7=»Да»;F5*0,0825;0)

В этом примере формула в ячейке F7 означает: ЕСЛИ(E7 = «Да», то вычислить общую сумму в ячейке F5 и умножить на 8,25 %, в противном случае налога с продажи нет, поэтому вернуть 0)

Примечание: Если вы используете текст в формулах, заключайте его в кавычки (пример: «Текст»). Единственное исключение — слова ИСТИНА и ЛОЖЬ, которые Excel распознает автоматически.

Распространенные неполадки

0 (ноль) в ячейке

Не указан аргумент значение_если_истина или значение_если_ложь. Чтобы возвращать правильное значение, добавьте текст двух аргументов или значение ИСТИНА/ЛОЖЬ.

Как правило, это указывает на ошибку в формуле.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

К какой категории относится функция если

������� ���������� ��������� MS Office 2007: Microsoft Excel

Итоговые функции в Excel

Некоторые функции Excel возвращают одно значение, в то время как аргументом имеют блок или несколько блоков. Такие функции будем называть итоговыми . Наиболее часто используемой из таких функций является Автосумма (СУММ) — для ее ввода во вкладке Главная размещена специальная кнопка ∑ т, а во вкладке Формулы — ∑ Автосумма — . Эта функция как бы подводит итог колонке чисел — отсюда и название для всей группы. Эти функции входят в категории Статистические и Математические .

Функция СУММ допускает до 30 аргументов. Поэтому с ее помощью можно находить сумму чисел из нескольких блоков. Допустима, например, такая формула =СУММ (В2:В9;12;-4.96; А4:С18) . Если в блоке в какой-либо ячейке находится текстовое значение, то оно считается равным нулю.

Кроме суммы, к итоговым функциям относятся, например: МАКС и МИН — вычисление максимального и минимального значений, СРЗНАЧ — среднее арифметическое значение и т.д. Чтобы быстро вычислить итоговые функции, необходимо выделить ячейку или диапазон с данными, для которых вы хотите ввести итоговую функцию, щелкнуть по стрелке рядом со значками ∑или ∑ Автосумма — и выбрать соответствующую функцию. В тоже время все эти итоговые функции для данного диапазона можно увидеть в строке состояния, если ее настроить. Для этого необходимо щелкнуть правой кнопкой мыши в строке состояния, в открывшемся меню с до­полнительными функциями можно выбрать по одной или все сразу такие функции как:

Среднее, Количество, Количество чисел, Максимум, Минимум и Сумма . Если строка состояния настроена, то после выбора диапазона ячеек, на ней сразу можно увидеть значения выбранных функций для данного диапазона.

К итоговым можно отнести функции И и ИЛИ .

Имеются данные метеостанции — количество осадков (в мм) (рис.90). Необходимо получить суммарное, максимальное, минимальное и среднемесячное количество осадков.

Введите формулы вышеописанным способом:

  • в В17 =СУММ (ВЗ :В14) ;
  • в В18: =МАКС(В 3:В14);
  • в В19: =МИН (ВЗ : В14) ;
  • в В20:=СРЗНАЧ (ВЗ:В14) .

Далее эти формулы скопированы В18:D20 .B блоке Е17:Е20 подведены итоги за три года. В Е17 формула = СУММ (В17 : D17), в Е18: =МАКС (В18 : D18) и т.д. На результаты наложен формат: одна цифра после десятичного разделителя (кнопка Главная – Число — Уменьшить разрядность . Если после запятой знаков больше 1, то уменьшите кнопкой Уменьшить разрядность

Существует две полезные функции, примыкающие к итоговым: СЧЕТЕСЛИ и СУММЕСЛИ . Их названия показывают, что они считают и суммируют не все данные, а только удовлетворяющие некоторому критерию.

Функция СЧЕТЕСЛИ (интервал; критерий) подсчитывает в интервале (т.е. блоке) количество значений, удовлетворяющих критерию.

В случае применения нескольких критерий целесообразно исполь­зовать функции СЧЕТЕСЛИМН и СУММЕСЛИМН .

Вычислим количество засушливых месяцев, т.е. месяцев, когда выпадало менее 10 мм осадков (рис.91).

Функция СУММЕСЛИ (интервал; критерий; сумм_интервал) устроена сложнее. Значения, удовлетворяющие критерию, выбираются из блока, заданного первым аргументом, суммируются соответствующие значения из сумм_интервал, заданного третьим аргументом. Если третий аргумент опущен, то суммируются ячейки в аргументе интервал.

Предположим, нужно вычислить суммарные осадки, которые выпали в незасушливые месяцы.

Дополним таблицу (рис.92).

В ячейку В23 введена формула =СУММЕСЛИ(ВЗ:В14;»>=10″) , далее скопированная в С23 :D23.

С помощью этой функции можно решить более трудную задачу: каково суммарное количество осадков было в 1993 г. в те месяцы, которые в 1994 г. были засушливыми. Решение дается формулой =СУММЕСЛИ (D3:D14; »

К итоговым можно отнести еще две функции: НАИБОЛЬШИЙ(блок;к) и НАИМЕНЬШИЙ(блок;к). Первая из этих функций возвращает к-е наибольшее значение из множества данных, а вторая — наименьшее.

В ячейки A1:D1 введем набор чисел. В блок А2:А5 введем формулы, которые показаны в соседнем столбце (рис. 93).

Для понимания работы функции важно отметить, что, если второй аргумент функции равен единице, то выбирается наибольшее значение в диапазоне заданных чисел. Если аргумент равен двум, второе наибольшее значение и т.д. Для заданного диапазона чисел третье наибольшее значение в блоке не 2, как можно было бы подумать, а 6, т.е. совпадает со вторым наибольшим значением. Заметьте, если в блоке n элементов, то функция НАИБОЛЬШИЙ (блок,n) возвращает минимальное значение, что мы и видим в примере.

Обратите внимание, что в А2:А5 получен исходный массив чисел, отсортированный по убыванию. Если в исходном блоке изменить какое- либо число, то блок А2:А5 будет автоматически перестроен. В этом отличие от операции сортировки, которая проводится самим пользователем при необходимости.

Обязательно сохраните результаты примеров 5.5-5.6, так как мы будем их использовать позднее.

Категории встроенных функций Excel

Все встроенные функции Excel разделены на несколько категорий. Например, функции категории Текстовые используются, в основном, для работы с текстовыми строками. Математические функции, с помощью которых можно составлять различные математические выражения, отнесены к категории Математические и т.п. Основные категории функций перечислены ниже. Все названия категорий соответствуют названиям команд, расположенным в группе Библиотека функций на вкладке Формулы.

Логические функции

Категория Логические содержит семь функций, в том числе функции ЕСЛИ и ЕСЛИОШИБКА. Использование логических функций делает формулы более гибкими, а использование функции ЕСЛИ наделяет формулу способностью «принимать решения». Благодаря этому функция ЕСЛИ стала самой используемой логической функцией. Функция ЕСЛИОШИБКА имеется в библиотеке встроенных функций только в Excel 2010 (2007). Об этом необходимо помнить, если ваши рабочие книги используются в разных версиях Excel.

Текстовые функции

Текстовые функции предназначены для обработки текста, например если создаете информационную базу про бесплатные программы скачать. Например, с помощью функций ПРОПНАЧ или ДЛСТР можно изменить регистр или определить длину текстовой строки. Используя текстовые функции, можно объединить несколько строк в одну или, наоборот, разделить одну текстовую строку на несколько строк. Например, формула =СЦЕПИТЬ(A1;A2) объединяет две текстовые строки, содержащиеся в ячейках A1 и A2, в одну.

Функции категории Проверка свойств и значений

Функции этой категории часто называют информационными. Функция ЯЧЕЙКА этой категории позволяет получить информацию о ячейке. Другие информационные функции проверяют выполнение какоголибо условия и, в зависимости от результата, возвращают значение ИСТИНА или ЛОЖЬ (или числовое значение). Например, с помощью функции ЕЧИСЛО можно проверить, данные какого типа содержит ячейка. Если в ячейке содержится число, функция ЕЧИСЛО возвращает логическое значение ИСТИНА, в противном случае функция возвращает логическое значение ЛОЖЬ.

Функции Дата и время

Функции, принадлежащие к этой категории, предназначены для работы со значениями даты и времени. По сути, эти функции работают с числовыми значениями, потому что дата и время в Excel являются числами, к которым применен один из числовых форматов даты и времени. С помощью функции этой категории можно вычислить количество рабочих дней между двумя датами (функция ЧИСТРАБДНИ), преобразовать дату в год (функция ГОД), месяц (функция МЕСЯЦ) или день недели (функция ДЕНЬНЕД) и т.п.

Математические функции

Математические функции позволяют выполнять простые и сложные вычисления. В категорию Математические входят тригонометрические функции, например SIN, COS, ACOS; функции, выполняющие арифметические действия, например СУММ, ПРОИЗВЕД, ЧАСТНОЕ; и многие другие функции. К этой же категории относятся функции, позволяющие работать с массивами значений или матрицами, — МУМНОЖ, МОПРЕД и МОБР, а также функции АГРЕГАТ и ПРОМЕЖУТОЧНЫЕ.ИТОГИ, которые используются для получения итоговых значений (суммы, среднего арифметического, минимального или максимального значений и т.п.) в массивах данных или списках. Функция АГРЕГАТ доступна только в Excel 2010!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *