Как в эксель быстро протянуть формулу до конца таблицы
Перейти к содержимому

Как в эксель быстро протянуть формулу до конца таблицы

  • автор:

Заполнение формулой смежных ячеек

. При заполнении формул вниз будут заложены относительные ссылки, чтобы гарантировать, что формулы будут корректироваться для каждой строки, если не включить абсолютные или смешанные ссылки перед заполнением формулы вниз.

Чтобы заполнить формулу и выбрать параметры для применения, выполните указанные здесь действия.

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.
  2. Перетащите маркер заполнения

  1. Щелкните Параметры >файла
  2. Выберите пункт Дополнительно.
  3. В окне Параметры правкив поле Включить перетаскивать ячейки и заполнять ячейки.

Дополнительные сведения о копировании формул см. в статье Копирование и вставка формулы в другую ячейку или на другой лист.

Заполнение смежных ячеек формулами

Для заполнения формулы смежным диапазоном ячеек можно использовать команду Заполнить. Просто сделайте следующее:

  1. Вы выберите ячейку с формулой и смежные ячейки, которые нужно заполнить.
  2. Щелкните Главная >заливкаи выберите Вниз ,Справа,Вверхили Влево.

Включить вычисление книги

При заполнении ячеек формулы не пересчитыются, если автоматическое вычисление книги не включено.

Вот как его можно включить:

  1. Выберите Файл >Параметры.
  2. Щелкните Формулы.
  3. В области Вычисления в книгевыберите Авто.

Маркер заполнения

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.
  2. Перетащите

Сочетания клавиш: Можно также нажать CTRL+D, чтобы заполнить формулой ячейку в столбце, или CTRL+R, чтобы заполнить формулой ячейку справа в строке.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Как в эксель быстро протянуть формулу до конца таблицы

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Скопируйте формулу, перетащив дескриптор заполнения в Excel для Mac

С помощью маркера заполнения можно быстро копировать формулы в смежные ячейки.

Маркер заполнения

При перетаскивании маркера в другие ячейки Excel показывает разные результаты для каждой ячейки.

Копирование формулы с помощью маркера заполнения

Курсор на маркере заполнения

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.
  2. Поместите курсор в правый нижний угол, чтобы он принял вид знака плюс (+). Например:

Курсор, перетаскивающий вниз маркер заполнения

Перетащите маркер заполнения вниз, вверх или по ячейкам, которые нужно заполнить. В этом примере на рисунке показано перетаскивание дескриптора заполнения вниз:

Показаны значения для заполненных ячеек

Когда вы отпустите маркер, формула будет автоматически применена к другим ячейкам.

Кнопка

Чтобы изменить способ заполнения ячеек, нажмите кнопку Параметры автозаполнения

Дополнительные сведения о копировании формул см. в статье Копирование и вставка формулы в другую ячейку или на другой лист.

  • Вы также можете нажать клавиши CTRL+D, чтобы заполнить формулу вниз в столбце. Сначала выберите ячейку с формулой, которую нужно заполнить, затем выделите ячейки под ней и нажмите клавиши CTRL+D.
  • Можно также нажать клавиши CTRL+R, чтобы заполнить формулу справа в строке. Сначала выберите ячейку с формулой, которую вы хотите заполнить, затем выделите ячейки справа от нее и нажмите клавиши CTRL+R.

Если заполнение не работает

Иногда заполнение работает нормально, а в других случаях это не работает так, как вы ожидаете. Поэтому важно проверить ссылки на ячейки в первой ячейке.

Ссылки на ячейки — это просто указатели на другие ячейки. Например, пусть первая ячейка содержит такую формулу:

A1 и B1 являются относительными ссылками. Это просто означает, что при заполнении формулы ссылки будут постепенно меняться с A1, B1 на A2, B2 и т. д., как показано ниже:

=СУММ(A1;B1)

=СУММ(A2;B2)

=СУММ(A3;B3)

В других случаях может не потребоваться, чтобы ссылки на другие ячейки изменялись. Например, вы хотите, чтобы первая ссылка A1 оставалась фиксированной, а B1 изменялась при перетаскивании маркера заполнения. В этом случае необходимо ввести знак доллара ($) в первой ссылке: =SUM($A$1,B1). Знак доллара заставляет Excel продолжать указывать на A1 при заполнении других ячеек. Это может выглядеть таким образом:

=СУММ($A$1;B1)

=СУММ($A$1;B2)

=СУММ($A$1;B3)

Ссылки со знаками доллара ($) называются абсолютными. При заполнении ячеек вниз ссылка на A1 остается фиксированной, но ссылку B1 приложение Excel изменяет на B2 и B3.

Есть проблемы с отображением маркера заполнения?

Если маркер не отображается, возможно, он скрыт. Чтобы отобразить его, выполните приведенные далее действия.

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Правка.
  3. В разделе Параметры правки установите флажок Включить маркер заполнения и перетаскивание ячеек.

Если автоматическое вычисление книги не работает, формулы не будут пересчитывать при заполнении ячеек.

Ниже описано, как его включить.

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Вычисление.
  3. В разделе Параметры вычисления убедитесь, что выбран параметр Автоматически .

Как в эксель быстро протянуть формулу до конца таблицы

Очень часто наблюдаю такую картину. Человек пытается «растянуть» формулу расположенную, например, в ячейке » E2 » на диапазон, скажем, » E3:E5000 «. И выглядит это очень грустно: палец на мышке затекает, глаза слезятся от проносящихся по экрану строк. А между тем эту задачу можно решить в один клик мышки.

Как это делается? Имеем такую таблицу с вбитой в ячейку «E2» формулой суммы:

Как быстро протянуть формулы?

Ставим курсор на ячейку с формулой и наводим мышку на правый нижний угол курсора так чтобы курсор мышки превратился в крестик:

Видео

Как включить видео?

Анимация

Чтобы увидеть видео включите в браузере GIF-Анимацию.

Теперь щелкаем левой клавишей мышки 2 раза, и формула «растягивается» на всю таблицу:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *