Как получить имя базы 1с программно
Перейти к содержимому

Как получить имя базы 1с программно

  • автор:

Как узнать имя вида объекта, например, имя используемого справочника?

Для того чтобы получить имя объекта, следует воспользоваться свойством «Имя» объекта метаданных, который можно получить методом «Метаданные».

Например, если «Справ» — это ссылка на элемент справочника, тогда имя этого справочника, заданное в конфигураторе, можно получить следующим образом:

ИмяСправочника Для типов, не имеющих метода Метаданные() , можно использовать поиск в структуре метаданных конфигурации. Например, если переменная "ВыборкаНоменклатуры" имеет тип СправочникВыборка.Номенклатура, тогда:
ОбъектОписания  

Как получить имя базы 1с программно

Интересует вариант получения имени базы данных для SQL варианта. Хочу получить ПРОГРАММНО следующий параметр, который указывается при подключении «Ref="LoveBase1c";»

Глобальный контекст
СтрокаСоединенияИнформационнойБазы (InfoBaseConnectionString)
Синтаксис:
СтрокаСоединенияИнформационнойБазы()
Возвращаемое значение:
Тип: Строка.
Описание:
Возвращает строку соединения информационной базы, которую, например, можно использовать для запуска 1С:Предприятия из языка в Automation, COM-соединение. Пример результата метода: File="C:\1cv8\Base".

НСтр(СтрокаСоединенияИнформационнойБазы(), "Ref");

ИмяЭтойИнформационнойБазы (БСП)

  • Имя этой информационной базы. Получает имя этой информационной базы из константы или из синонима конфигурации.

    // Получает имя этой информационной базы из константы или из синонима конфигурации. // (Только для внутреннего использования). // Функция ИмяЭтойИнформационнойБазы() Экспорт УстановитьПривилегированныйРежим(Истина); Результат = Константы.ЗаголовокСистемы.Получить(); Если ПустаяСтрока(Результат) Тогда Результат = Метаданные.Синоним; КонецЕсли; Возврат Результат; КонецФункции /////////////////////////////////////////////////////////////////////////////////////////////////////// // Copyright (c) 2019, ООО 1С-Софт // Все права защищены. Эта программа и сопроводительные материалы предоставляются // в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0) // Текст лицензии доступен по ссылке: // https://creativecommons.org/licenses/by/4.0/legalcode ///////////////////////////////////////////////////////////////////////////////////////////////////////
    // Получает имя этой информационной базы из константы или из синонима конфигурации. // (Только для внутреннего использования). // Функция ИмяЭтойИнформационнойБазы() Экспорт УстановитьПривилегированныйРежим(Истина); Результат = Константы.ЗаголовокСистемы.Получить(); Если ПустаяСтрока(Результат) Тогда Результат = Метаданные.Синоним; КонецЕсли; Возврат Результат; КонецФункции /////////////////////////////////////////////////////////////////////////////////////////////////////// // Copyright (c) 2019, ООО 1С-Софт // Все права защищены. Эта программа и сопроводительные материалы предоставляются // в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0) // Текст лицензии доступен по ссылке: // https://creativecommons.org/licenses/by/4.0/legalcode ///////////////////////////////////////////////////////////////////////////////////////////////////////

    Как получить имя базы 1с программно

    Глобальный контекст (Global context)
    СтрокаСоединенияИнформационнойБазы (InfoBaseConnectionString)
    Синтаксис:

    СтрокаСоединенияИнформационнойБазы()
    Возвращаемое значение:

    Возвращает Строка соединения информационной базы, которую, например, можно использовать для запуска 1С:Предприятия средствами встроенного языка в Automation, Менеджер COM-соединений. Пример результата метода: File="C:\1cv8\Base".

    Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

    Добавлено 11.07.14, 09:45
    Получаешь строку и разбираешь ее - это уже не сложно.

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *