Как размножить формулу в excel
Перейти к содержимому

Как размножить формулу в excel

  • автор:

Как размножить формулу в excel

Данная команда разносит значения ячеек указанного столбца таблицы по отдельным строкам:

Размножить столбец по строкам

Чтобы воспользоваться данной командой выделите таблицу, перейдите во вкладку «ЁXCEL» Главного меню, нажмите кнопку «Таблицы» и выберите команду «Размножить столбец по строкам»:

razmnozhit-stolbets-po-strokam

В открывшемся диалоговом окне укажите столбец, ячейки которого необходимо размножить. Выберите знак — разделитель, по которому следует разделять данные (можно указать свой) и нажмите :

razmnozhit-stolbets-po-strokam

Программа создаст новый лист в книге и сформирует на нем таблицу с размноженными по строкам ячейками указанного столбца:

Для отмены операции нажмите кнопку «Отмены последнего действия» на панели быстрого доступа или сочетание клавиш «Ctrl+Z» — вставленный лист со сформированной таблицей будет удален.

Скопируйте формулу, перетащив дескриптор заполнения в Excel для Mac

С помощью маркера заполнения можно быстро копировать формулы в смежные ячейки.

Маркер заполнения

При перетаскивании маркера в другие ячейки Excel показывает разные результаты для каждой ячейки.

Копирование формулы с помощью маркера заполнения

Курсор на маркере заполнения

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.
  2. Поместите курсор в правый нижний угол, чтобы он принял вид знака плюс (+). Например:

Курсор, перетаскивающий вниз маркер заполнения

Перетащите маркер заполнения вниз, вверх или по ячейкам, которые нужно заполнить. В этом примере на рисунке показано перетаскивание дескриптора заполнения вниз:

Показаны значения для заполненных ячеек

Когда вы отпустите маркер, формула будет автоматически применена к другим ячейкам.

Кнопка

Чтобы изменить способ заполнения ячеек, нажмите кнопку Параметры автозаполнения

Дополнительные сведения о копировании формул см. в статье Копирование и вставка формулы в другую ячейку или на другой лист.

  • Вы также можете нажать клавиши CTRL+D, чтобы заполнить формулу вниз в столбце. Сначала выберите ячейку с формулой, которую нужно заполнить, затем выделите ячейки под ней и нажмите клавиши CTRL+D.
  • Можно также нажать клавиши CTRL+R, чтобы заполнить формулу справа в строке. Сначала выберите ячейку с формулой, которую вы хотите заполнить, затем выделите ячейки справа от нее и нажмите клавиши CTRL+R.

Если заполнение не работает

Иногда заполнение работает нормально, а в других случаях это не работает так, как вы ожидаете. Поэтому важно проверить ссылки на ячейки в первой ячейке.

Ссылки на ячейки — это просто указатели на другие ячейки. Например, пусть первая ячейка содержит такую формулу:

A1 и B1 являются относительными ссылками. Это просто означает, что при заполнении формулы ссылки будут постепенно меняться с A1, B1 на A2, B2 и т. д., как показано ниже:

=СУММ(A1;B1)

=СУММ(A2;B2)

=СУММ(A3;B3)

В других случаях может не потребоваться, чтобы ссылки на другие ячейки изменялись. Например, вы хотите, чтобы первая ссылка A1 оставалась фиксированной, а B1 изменялась при перетаскивании маркера заполнения. В этом случае необходимо ввести знак доллара ($) в первой ссылке: =SUM($A$1,B1). Знак доллара заставляет Excel продолжать указывать на A1 при заполнении других ячеек. Это может выглядеть таким образом:

=СУММ($A$1;B1)

=СУММ($A$1;B2)

=СУММ($A$1;B3)

Ссылки со знаками доллара ($) называются абсолютными. При заполнении ячеек вниз ссылка на A1 остается фиксированной, но ссылку B1 приложение Excel изменяет на B2 и B3.

Есть проблемы с отображением маркера заполнения?

Если маркер не отображается, возможно, он скрыт. Чтобы отобразить его, выполните приведенные далее действия.

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Правка.
  3. В разделе Параметры правки установите флажок Включить маркер заполнения и перетаскивание ячеек.

Если автоматическое вычисление книги не работает, формулы не будут пересчитывать при заполнении ячеек.

Ниже описано, как его включить.

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Вычисление.
  3. В разделе Параметры вычисления убедитесь, что выбран параметр Автоматически .

Перемещение и копирование формулы

Важно знать о возможностях изменения относительной ссылки на ячейку при перемещении или копировании формулы.

  • Перемещение формулы: При перемещении формулы ссылки на ячейки в формуле не изменяются независимо от типа используемой ссылки на ячейку.
  • Копирование формулы: При копировании формулы относительные ссылки на ячейки изменятся.

Перемещение формулы

  1. Выделите ячейку с формулой, которую необходимо переместить.
  2. В группе Буфер обмена на вкладке Главная нажмите кнопку Вырезать. Формулы можно скопировать и путем перетаскивания границы выделенной ячейки в левую верхнюю ячейку области вставки. Это заменит все существующие данные.
  3. Выполните одно из следующих действий:
    • Чтобы вставить формулу и любое форматирование: в группе Буфер обмена на вкладке Главная нажмите кнопку Вставить.
    • Чтобы вставить только формулу, в группе Буфер обмена на вкладке Главная нажмите кнопку Вставить, выберите Специальная вставка, а затем — Формулы.

Копирование формулы

  1. Выделите ячейку, содержащую формулу, которую требуется скопировать.
  2. В группе Буфер обмена на вкладке Главная нажмите кнопку Копировать.
  3. Выполните одно из указанных ниже действий.
  4. Чтобы вставить формулу и любое форматирование, в группе Буфер обмена на вкладке Главная нажмите кнопку Вставить.
  5. Чтобы вставить только формулу, в группе Буфер обмена на вкладке Главная нажмите кнопку Вставить, выберите Специальная вставка, а затем — Формулы.

Примечание: Можно вставить только результаты формулы. В группе Буфер обмена на вкладке Главная нажмите кнопку Вставить, выберите Специальная вставка, а затем — Значения.

  1. Выделите ячейку с формулой.
  2. В строке формул строка формул

Копируемая формула

Первоначальная ссылка

Новая ссылка

$A$1 (абсолютный столбец и абсолютная строка)

A$1 (относительный столбец и абсолютная строка)

$A1 (абсолютный столбец и относительная строка)

A1 (относительный столбец и относительная строка)

Примечание: Вы также можете копировать формулы в смежные ячейки с помощью маркер заполнения

. Убедившись, что ссылки на ячейки в формуле дают результат, который требуется на шаге 4, выделите ячейку, содержащую скопированную формулу, а затем перетащите маркер заполнения в диапазон, который нужно заполнить.

Перемещение формул очень похоже на перемещение данных в ячейках. Единственное, что нужно watch, так это то, что ссылки на ячейки, используемые в формуле, по-прежнему нужны после перемещения.

Команда

  1. Выделите ячейку, содержащую формулу, которую нужно переместить.
  2. Щелкните Главная >Вырезать (или нажмите клавиши CTRL+X).

Команда

Выделите ячейку, в которой должна быть формула, и нажмите кнопку Вставить (или нажмите клавиши CTRL+V).

Щелкните правой кнопкой мыши, чтобы увидеть команды

Совет: Вы также можете щелкнуть правой кнопкой мыши ячейки, чтобы вырезать и вставить формулу.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Как размножить формулу на большой диапазон (Excel)?

Например Вам нужно заполнить столбец В от первой строки (В1) до строки 10000 (В10000). Копируйте ячейку В1 (правой кнопкой мыши) , затем выделите ячейку В2 (левой кнопкой мыши) , спуститесь до ячейки В10000 (колесом мыши или скроллингом) , нажмите SHIFT и не отпуская этой кнопки выделите В10000 (левой кн. мыши) . В результате у Вас выделится диапазон В2 — В10000. В выделенном диапазоне щелкните правой кнопкой мыши, выберите СПЕЦИАЛЬНАЯ ВСТАВКА, затем щелкните в строку ФОРМУЛЫ и нажмите ОК. В результате весь выделенный диапазон В2-В10000 заполнится формулой ячейки В1.

Остальные ответы

Копируешь ячейку с формулой и вставляешь до самого низа.

Копируете формулу, выделяете диапазон и вставляете.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *