Порт 23 служба telnet tcp как закрыть на роутере
Перейти к содержимому

Порт 23 служба telnet tcp как закрыть на роутере

  • автор:

Порт 23 служба telnet tcp как закрыть на роутере

Дорогие пользователи! У нас появился новый форум на платформе tp-link.community (Сообщество)

Если при регистрации в Сообществе Вы укажете адрес электронный почты, который используете на данном форуме, то Ваши данные будут перенесены на форум Сообщества автоматически.
Также, если на форуме Сообщества Ваш никнейм будет занят, то Вам предложат сменить его или оставить, но с приставкой «_RU».

Убедительная просьба не дублировать темы на старом/новом форуме.

Информация

Запрошенной темы не существует.

Как проверить, открыт ли порт

Чтобы обмениваться данными по локальной сети или через интернет, устройства должны связаться друг с другом. Для этого каждому из них необходимо иметь собственный IP-адрес и открытые порты для взаимодействия. В статье подробно разберем, что такое порт, зачем он нужен и как самостоятельно проверить его доступность.

Что такое порт сервера и зачем он нужен

Порт можно сравнить с разъемами на материнской плате, только если в том случае речь идет о подключении физических устройств, то здесь – о виртуальных процессах. Представьте: на вашем устройстве находится много разных сетевых приложений, но вам нужно найти и подключится к одному конкретному. Порт нужен именно для того, чтобы открыть с ним соединение и дождаться завершения процесса. Сам порт выглядит как числовой идентификатор от 0 до 65 535.

Перед тем, как подключится к любому порту, нужно проверить, открыт ли он. Большинство программ делают проверку доступности порта автоматически, но иногда требуется сделать это самостоятельно. В случае если порт будет несвободен, установить соединение не получится.

Один из наиболее распространенных способов проверить доступность порта – сделать это с помощью команды Telnet. Дальше расскажем, как именно это сделать.

Telnet: что это такое и как ей пользоваться

Что такое Telnet? Telnet – это сетевая утилита, позволяющая установить соединение с удаленным портом любого компьютера и каналом связи. Она работает по протоколу TELNET и позволяет им управлять. Сам протокол работает на основе TCP – то есть, можно передавать обычные строковые команды на другое устройство. Также его можно использовать для взаимодействия между процессами. Как правило, утилита установлена по умолчанию во всех системах. Если на вашем устройстве ее нет – воспользуйтесь и установите Telnet в одном из официальных репозиториев, например, в Ubuntu:

$ sudo apt install telnet

Общий синтаксис утилиты Telnet выглядит следующим образом:

$ telnet опции хост порт

Разберем по порядку, что здесь подразумевается.

Хост – это удаленный компьютер (домен или IP-адрес).

Порт – тот порт, через который устанавливается соединение, то есть на этом компьютере.

Опции необходимы, чтобы подключиться к удаленному серверу. Самые распространенные опции выглядят так:

  • -4 – использовать поддержку стандарта IPv4;
  • -6 – использовать поддержку стандарта IPv6;
  • -8 – использовать 8-битную кодировку – например, Unicode;
  • -E – отключить поддержку Escape-последовательностей;
  • -a – автоматический вход с логином из переменного окружения USER;
  • -b – использовать локальный сокет;
  • -d – использовать режим отладки;
  • -p – использовать эмуляцию rlogin;
  • -l – указать пользователя авторизации.

После подключения к удаленному серверу нужно ввести команды для управления процессами. Для этого у Telnet есть два режима:

  • Построчный – строка полностью редактируется на локальном компьютере и в готовом виде целиком отправляется на сервер.
  • Посимвольный – каждый символ, который вы набираете, отправляется на сервер. В этом случае не получится что-то исправить, если вы допустите ошибку при вводе.

Стандартные команды утилиты Telnet

Мы не будем рассматривать все существующие команды, возьмем только самые необходимые. Подробную информацию о них можно найти в официальной документации разработчиков программы.

  • CLOSE – отключить соединение с удаленным сервером;
  • ENCRYPT – передавать всю информацию в зашифрованном виде;
  • LOGOUT – выйти и закрыть соединение;
  • MODE – переключить режима со строчного на символьный или наоборот;
  • STATUS – показать текущий статус соединения;
  • SEND – отправить один из специальных символов telnet;
  • SET – установить значение параметра;
  • OPEN – открыть соединение с удаленным сервером;
  • DISPLAY – показать используемые спецсимволы;
  • SLC – изменить используемые спецсимволы.

Как проверить, открыт ли порт на удаленном компьютере, с помощью Telnet

Команда Telnet – отличный вариант, чтобы проверить доступность порта на удаленном компьютере. Как проверить доступность порта через Telnet? Чтобы это сделать, нужно ввести в командной строке одну из команд:

В командной строке Windows введите одну из команд:

telnet имя_сервера номер_порта или telnet IP_сервера номер_порта

Если вы увидите в ответе терминала или командной строки ошибку, то можно сделать вывод, что порт закрыт.

Если вы видите пустое окно или появилось приглашение сервера, то порт открыт.

Также с Telnet можно посмотреть открытые порты linux:

  1. Запустите терминал комбинацией клавиш Ctrl+Alt+T
  2. Введите команду, чтобы установить утилиту: sudo apt install telnet
  3. После установки введите команду в терминале: telnet имя_сервера номер_порта
  4. Если появится ошибка, то порт закрыт. Если порт открыт, вы увидите сообщение Unable to connect to remote host.

Как проверить открытые порты на локальном компьютере

Открытые порты на локальном компьютере, например, который вы используете дома или для работы, могут привести к серьезным последствиям – именно через них на устройства проникают вирусы и есть риск стать жертвой злоумышленников. Помимо Telnet есть еще несколько встроенных утилит, которые можно использовать, если вам нужно проверить открытые и закрытые соединения. Рассмотрим, как проверить, открыт ли порт на компьютере, примере утилиты netstat.

Как проверить порты в Windows, используя утилиту netstat:

  1. Введите комбинацию клавиш Win+R
  2. Задайте команду CMD и нажмите Enter
  3. Задайте команду netstat –a и нажмите Enter

После этого перед вами должен появиться список занятых портов, где также будет видно, какая программа его использует. Чтобы выгрузить файл и проверить его на наличие лишних приложений, задайте команду netstat –a >имя.txt.

Как еще можно проверить доступность порта

Онлайн-сервис ping.eu

Если вы не хотите использовать утилиты для проверки, есть онлайн-сервисы, которые помогут это сделать.

Один из таких сервисов – ping.eu. Это многофункциональный сервер, который позволяет быстро проверить открытые порты. Нужно зайти на сайт, выбрать вкладку Port check. Далее понадобится ввести IP-адрес и номер соединения, адрес пользователя будет определен автоматически. После этого нажмите Go и сервис покажет результат.

Специальные программы

Кроме онлайн-сервисов и встроенных утилит, можно воспользоваться для проверки портов отдельными приложениями. Их достаточно много, и они работают примерно по одному принципу, при необходимости вы можете найти подходящее для себя через поиск. Мы рассмотрим, как работает программа Portforward Network Utilities. Она является платной, но можно выбрать пробный режим. Кстати, эта программа поможет не только проверить порты, но и открыть их, если вам это нужно.

Как проверить порты с помощью Portforward Network Utilities

  1. Перейдите на сайт разработчика и скачайте приложение в разделе загрузок.
  2. Запустите приложение и выберите режим использования. Можно использовать бесплатный режим или оплатить на сайте – тогда нужно ввести регистрационный ключ.
  3. Откройте раздел Tools и выберите пункт Port Checker.
  4. Введите номер порта и выберите протокол передачи информации.
  5. Нажмите кнопку Check Me и дождитесь результатов сканирования.

Заключение

Один из аспектов безопасности – это закрытые порты, поэтому если регулярно их проверять, то вы сможете не допустить утечки ваших данных и доступа злоумышленников. При этом порты иногда необходимо открыть, чтобы настроить некоторые программы, приложения или сервисы операционной системы. Проверку портов можно провести с помощью встроенных утилит, онлайн-сервисов или специальных программ, которые понадобится скачать отдельно. Какой из инструментов выбрать – вопрос только ваших предпочтений и требований.

Порт 23 служба telnet tcp как закрыть на роутере

Не могу закрыть подозрительные порты

#sh control-plane host open-ports
Active internet connections (servers and established)
Prot Local Address Foreign Address Service State
tcp *:22 192.168.0.105:50765 SSH-Server ESTABLIS
tcp *:22 *:0 SSH-Server LISTEN
tcp *:23 *:0 Telnet LISTEN
udp *:4500 *:0 ISAKMP LISTEN
udp *:1975 *:0 IPC LISTEN
udp *:500 *:0 ISAKMP LISTEN

interface GigabitEthernet0/0
description «WAN»
ip address *********** 255.255.255.248
ip access-group FEREAWLL_IN in
ip access-group FW_OUT out
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

ip access-list extended FIREWALL_IN
permit tcp any any eq 22

ip access-list extended FW_OUT
permit icmp any any
deny udp any any range 135 netbios-ss
deny tcp any any range 135 139
deny tcp any any eq 445
deny tcp any any eq 593
deny udp any range 135 netbios-ss any
deny tcp any range 135 139 any
deny tcp any eq 445 any
deny tcp any eq 593 any
deny tcp any any eq 2002
deny tcp any any eq 4002
permit ip any any
!

ip inspect name FW tcp
ip inspect name FW udp
ip inspect name FW icmp

Зарегистрирован: 02 июн 2009, 14:42
Сообщения: 231

Почитайте. Как раз про эти порты.

Зарегистрирован: 27 мар 2013, 15:01
Сообщения: 18

Чёт только англоязычные форумы кишат инфой ни одного нашего. почитал всё ровно не пойму для чего нужен service-module Embedded-Service-Engine 0/0

это случайно не для того чтоб спец службы имели доступ. .

Да вот это помогло
outer#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#access-list 10 permit 192.168.1.2
Router(config)#line 2
Router(config-line)#access-class 10 in
Router(config-line)#end
Router#
Router#service-module Embedded-Service-Engine 0/0 session

Страница 1 из 1 [ Сообщений: 3 ]

Часовой пояс: UTC + 3 часа

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 13

Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Создано на основе phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.
Русская поддержка phpBB

Как пользоваться telnet

Telnet — это сетевая утилита, которая позволяет соединиться с удаленным портом любого компьютера и установить интерактивный канал связи, например, для передачи команд или получения информации. Можно сказать, что это универсальный браузер в терминале, который умеет работать со множеством сетевых протоколов.

Эта утилита очень часто использовалась раньше, для удаленного управления компьютером с Linux, но потом ей на замену пришел защищенный протокол SSH. Но telnet все еще используется, например, для тестирования сети, проверки портов, а также для взаимодействия с различными IoT устройствами и роутерами. В этой статье мы рассмотрим что такое telnet, а также как пользоваться telnet для решения своих задач.

Что такое Telnet?

Как я уже сказал, эта утилита предназначена для создания интерактивного соединения между удаленными компьютерами. Она работает по протоколу TELNET, но этот протокол поддерживается многими сервисами, поэтому ее можно использовать для управления ими. Протокол работает на основе TCP, и позволяет передавать обычные строковые команды на другое устройство. Он может использоваться не только для ручного управления но и для взаимодействия между процессами.

Для работы с этим протоколом мы будем использовать утилиту telnet, ею очень просто пользоваться. Давайте рассмотрим синтаксис telnet:

$ telnet опции хост порт

Хост — это домен удаленного компьютера, к которому следует подключиться, а порт — порт на этом компьютере. А теперь давайте рассмотрим основные опции:

  • -4 — принудительно использовать адреса ipv4;
  • -6 — принудительно использовать адреса ipv6;
  • -8 — использовать 8-битную кодировку, например, Unicode;
  • -E — отключить поддержку Escape последовательностей;
  • -a — автоматический вход, берет имя пользователя из переменной окружения USER;
  • -b — использовать локальный сокет;
  • -d — включить режим отладки;
  • — режим эмуляции rlogin;
  • -e — задать символ начала Escape последовательности;
  • -l — пользователь для авторизации на удаленной машине.

Это все, что касается команды telnet для установки соединения. Но соединение с удаленным хостом, это только полдела. После установки подключения telnet может работать в двух режимах:

  • Построчный — это предпочтительный режим, здесь строка текста редактируется на локальном компьютере и отправляется только тогда, когда она будет полностью готова. Но такая возможность есть не всегда и не у всех сервисов;
  • Посимвольный — все набираемые вами символы отправляются на удаленный сервер. Тут будет сложно что-либо исправить, если вы допустили ошибку, потому что Backspace тоже будет отправляться в виде символа и стрелки движения тоже.

Использование telnet заключается в передаче специальных команд. У каждого сервиса свои команды, но у протокола есть свои команды telnet, которые можно применять в консоли telnet.

  • CLOSE — закрыть соединение с сервером;
  • ENCRYPT — шифровать все передаваемые данные;
  • LOGOUT — выйти и закрыть соединение;
  • MODE — переключить режим, со строчного на символьный или с символьного на строчный;
  • STATUS — посмотреть статус соединения;
  • SEND — отправить один из специальных символов telnet;
  • SET — установить значение параметра;
  • OPEN — установить подключение через telnet с удаленным узлом;
  • DISPLAY — отобразить используемые спецсимволы;
  • SLC — изменить используемые спецсимволы.

Мы не будем рассматривать все команды, поскольку они вам вряд ли понадобятся, а если и понадобятся, то вы легко сможете их найти в официальной документации.

Как пользоваться telnet?

Дальше мы рассмотрим как использовать telnet для решения ваших задач. Обычно, утилита уже установлена в большинстве систем, но если это не так, то вы можете установить telnet из официальных репозиториев, например, в Ubuntu:

sudo apt install telnet

Теперь перейдем к применению утилиты. Изначально она использовалась для удаленного управления компьютером, но поскольку потом был разработан более безопасный протокол SSH, использовать ее перестали.

1. Доступность сервера

Утилита все еще может быть полезной при поверке доступности узла, для этого просто передайте ей ip адрес или имя хоста:

Для этого не обязательно применять telnet, есть ping.

2. Проверка порта

C помощью telnet мы можем проверить доступность порта на узле, а это уже может быть очень полезным. Чтобы проверить порт telnet выполните:

telnet localhost 123
$ telnet localhost 22

В первом случае мы видим, что соединение никто не принимает, во втором же выводится сообщение об успешном подключении и приветствие SSH сервера.

3. Отладка

Чтобы включить режим отладки и выводить более подробную информацию во время работы используйте опцию -d во время подключения:

sudo telnet -d localhost 22

4. Консоль telnet

Использование консоли telnet тоже важный момент в разборе как пользоваться telnet. В основном режиме вы можете выполнять команды, на удаленном сервере, если же вы хотите адресовать команду именно telnet, например, для настройки ее работы, необходимо использовать спецсимвол для открытия консоли, обычно утилита сразу говорит вам что это за символ, например, по умолчанию используется «^[«:

Для его активации вам нужно нажать сочетание клавиш Ctrl+[, затем вы уведите приглашение ввода telnet.

Чтобы посмотреть все доступные команды, вы можете набрать ?. Например, вы можете посмотреть статус подключения:

Здесь есть и другие интересные возможности. Такие вещи можно проделывать при любом подключении с помощью утилиты telnet.

5. Посмотреть сайт telnet

Один из распространенных способов использования telnet — это тестирование сайта из консоли. Да, красивую веб-страницу вы не получите, но можете вручную собрать запросы и видеть все переданные сервером данные.

telnet opennet.ru 80

Затем наберите команду веб-серверу:

Веб сервер вернет полностью страницу, а также заголовки, которые необходимы для ее отображения браузером.

6. Удаленное управление telnet

Настоятельно не рекомендуется использовать небезопасный telnet для удаленного управления, потому что все команды и пароли могут быть прослушаны сторонним пользователем. Но иногда, например, для роутеров telnet все же используется для удаленного управления. Все работает точно так же, как и для других подключений, только нужно использовать порт 23, а на удаленном компьютере должен быть установлен telnet-server:

telnet localhost 23

Тут порт можно даже не указывать, потому что по умолчанию будет использоваться именно 23. Далее, вам нужно ввести логин и пароль, а затем вы сможете выполнять команды в удаленной системе.

Выводы

В этой статье мы рассмотрели примеры использования telnet, а также что представляет из себя эта утилита, хотя она уже не используется по своему основному назначению, но до сих пор может быть полезной многим пользователям и системным администраторам. Если у вас остались вопросы, спрашивайте в комментариях!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *