Почему ложь в формуле эксель
Перейти к содержимому

Почему ложь в формуле эксель

  • автор:

Функция ЛОЖЬ

В этой статье описаны синтаксис формулы и использование false. функция в Microsoft Excel.

Описание

Возвращает логическое значение ЛОЖЬ.

Синтаксис

У функции ЛОЖЬ нет аргументов.

Замечания

Можно ввести слово ЛОЖЬ непосредственно на лист или в формулу, и в Microsoft Excel оно будет интерпретировано как логическое значение ЛОЖЬ. Функция ЛОЖЬ служит главным образом для обеспечения совместимости с другими приложениями для работы с электронными таблицами.

Почему ложь в формуле эксель

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Функция ИСТИНА

В этой статье описаны синтаксис формулы и использование функции ИСТИНА в Microsoft Excel.

Примечание: Функция ИСТИНА предназначена в первую очередь для обеспечения совместимости с другими редакторами электронных таблиц.

Описание

Возвращает логическое значение ИСТИНА. Эту функцию можно использовать, если значение ИСТИНА должно возвращаться при выполнении условия. Пример:

Значение ИСТИНА можно также вводить в ячейки и формулы напрямую, не используя эту функцию. Пример:

Если условие выполняется, значение ИСТИНА возвращается в Excel в обоих примерах. Если условие не выполняется, в обоих примерах в Excel возвращается значение ЛОЖЬ.

Синтаксис

У функции ИСТИНА нет аргументов.

Функция ИЛИ() в EXCEL

логическое_значение1 — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ИЛИ(A1>100;A2>100) Т.е. если хотя бы в одной ячейке (в A1 или A2 ) содержится значение больше 100, то формула вернет ИСТИНА, а если в обоих ячейках значения =ИЛИ(ЛОЖЬ;ЛОЖЬ) вернет ЛОЖЬ, а формулы =ИЛИ(ИСТИНА;ЛОЖЬ) или =ИЛИ(ЛОЖЬ;ИСТИНА) или =И(ИСТИНА;ИСТИНА) или =И(ЛОЖЬ;ЛОЖЬ;ИСТИНА) вернут ИСТИНА.

Функция воспринимает от 1 до 255 проверяемых условий. Понятно, что 1 значение использовать бессмысленно, для этого есть функция ЕСЛИ() . Чаще всего функцией ИЛИ() на истинность проверяется 2-5 условий.

Совместное использование с функцией ЕСЛИ()

Сама по себе функция ИЛИ() имеет ограниченное использование, т.к. она может вернуть только значения ИСТИНА или ЛОЖЬ, чаще всего ее используют вместе с функцией ЕСЛИ() : =ЕСЛИ(ИЛИ(A1>100;A2>100);»Бюджет превышен»;»В рамках бюджета»)

Т.е. если хотя бы в одной ячейке (в A1 или A2 ) содержится значение больше 100, то выводится Бюджет превышен , если в обоих ячейках значения И()

Функция И() также может вернуть только значения ИСТИНА или ЛОЖЬ, но, в отличие от ИЛИ() , она возвращает ИСТИНА, только если все ее условия истинны. Чтобы сравнить эти функции составим, так называемую таблицу истинности для И() и ИЛИ() .

Эквивалентность функции ИЛИ() операции сложения +

В математических вычислениях EXCEL интерпретирует значение ЛОЖЬ как 0, а ИСТИНА как 1. В этом легко убедиться записав формулы =ИСТИНА+0 и =ЛОЖЬ+0

Следствием этого является возможность альтернативной записи формулы =ИЛИ(A1>100;A2>100) в виде =(A1>100)+(A2>100) Значение второй формулы будет =0 (ЛОЖЬ), только если оба аргумента ложны, т.е. равны 0. Только сложение 2-х нулей даст 0 (ЛОЖЬ), что совпадает с определением функции ИЛИ() .

Эквивалентность функции ИЛИ() операции сложения + часто используется в формулах с Условием ИЛИ, например, для того чтобы сложить только те значения, которые равны 5 ИЛИ равны 10: =СУММПРОИЗВ((A1:A10=5)+(A1:A10=10)*(A1:A10))

Проверка множества однотипных условий

Предположим, что необходимо сравнить некое контрольное значение (в ячейке B6 ) с тестовыми значениями из диапазона A6:A9 . Если контрольное значение совпадает хотя бы с одним из тестовых, то формула должна вернуть ИСТИНА. Можно, конечно записать формулу =ИЛИ(A6=B6;A7=B6;A8=B6;A9=B6) но существует более компактная формула, правда которую нужно ввести как формулу массива (см. файл примера ): =ИЛИ(B6=A6:A9) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Вместо диапазона с тестовыми значениями можно также использовать константу массива : =ИЛИ(A18:A21>)

В случае, если требуется организовать попарное сравнение списков , то можно записать следующую формулу: =ИЛИ(A18:A21>=B18:B21)

Если хотя бы одно значение из Списка 1 больше или равно (>=) соответствующего значения из Списка 2, то формула вернет ИСТИНА.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *