Как в скд вывести свернутые группировки
Перейти к содержимому

Как в скд вывести свернутые группировки

  • автор:

Как в скд вывести свернутые группировки

Так же, как и без СКД.
Ну и если ты думаешь, что этот вопрос никогда никем не задавался — ты сильно ошибаешься

Тип группировки — иерархия
(3) Это в коде при выводе таблицы

ВнешниеНаборыДанных = Новый Структура;

ТаблицаДанных = СоздатьТаблицуДанных();
СхемаКомпоновкиДанных = ПолучитьМакет(«Логистика»);
ВнешниеНаборыДанных.Вставить(«Логистика»,ТаблицаДанных);

ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
Настройки = КомпоновщикНастроек.ПолучитьНастройки();
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки, ДанныеРасшифровки);

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеНаборыДанных, ДанныеРасшифровки);
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ЭлементыФормы.Результат.ФиксацияСлева = 1;

ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
ЭлементыФормы.Результат.Показать();

Как свернуть все группировки при открытии отчета СКД в 1с?

Ikasteko.ru

По умолчанию, группировки в отчетах 1с раскрыты, но для удобства часто их приходится сворачивать, чтобы видеть «всю картину» отчета. Если Вас больше интересует свернутый отчет в группировках, придется добавить несколько строк кода.

Ответ

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных; Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.ПолучитьНастройки(), ДанныеРасшифровки); ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных; ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки); ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; ПроцессорВывода.УстановитьДокумент(ДокументРезультат); ПроцессорВывода.Вывести(ПроцессорКомпоновки); //ДокументРезультат.ПоказатьУровеньГруппировокСтрок(2); //Уровень 3 //ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1); //Уровень 2 ДокументРезультат.ПоказатьУровеньГруппировокСтрок(0); //Уровень 1 КонецПроцедуры
Еще записи по теме
  • Как скачать музыку из вк
  • Что значит «error 404 — not found» на странице?
  • .bat файл не понимает русские буквы (кириллицу)
  • Как обрезать фото?
  • Как открыть файл .pdf?
  • Раздача wi-fi с ноутбука
  • Как установить шрифты?

СКД свернуть один уровень группировки по умолчанию

Добрый день, извиняюсь за глупый вопрос.
В СКД по умолчанию открывается отчет с развернутыми группировками, как можно сделать, чтобы по умолчанию открывался только с группировками до 2ого уровня?

По теме из базы знаний

  • Универсальный конструктор отчетов (Новейший отчет) для 1C 7.7
  • Рекомендации по эффективной работе в 1С
  • Свёртка таблицы без потери данных
  • Универсальные функции с примерами использования
  • Поблочная обработка таблицы. Обзор решений
  • Дата
  • Дата
  • Рейтинг всех уровней
  • Рейтинг 1-го уровня
  • Древо развёрнутое
  • Древо свернутое

Свернуть все

2. UtSpar 133 18.01.18 12:13 Сейчас в теме

(1)Процедура ДействияФормыДействие(Кнопка)
ЭлементыФормы.Результат.Очистить();
СкомпоноватьРезультат(ЭлементыФормы.Результат);
ЭлементыФормы.Результат.ПоказатьУровеньГруппировокСтрок(1);
КонецПроцедуры

Как свернуть группировки отчета в СКД программно в 1С

При формировании отчетов в СКД по умолчанию все группировки развернуты, но бывает что необходимо сразу после формирования показать отчет со свернутыми группировками в 1С.

Сворачиваем группировки до необходимого уровня (0,1,2 и т.д.) в 1С:

Процедура ПриКомпоновкеРезультата ( ДокументРезультат , ДанныеРасшифровки , СтандартнаяОбработка )

СтандартнаяОбработка = Ложь;

КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных ;

Макет = КомпоновщикМакет . Выполнить ( СхемаКомпоновкиДанных , КомпоновщикНастроек . Настройки , ДанныеРасшифровки ) ;

ПроцессорКомпоновк и = Новый ПроцессорКомпоновкиДанных ;

ПроцессорКомпоновки . Инициализировать ( Макет , , ДанныеРасшифровки ) ;

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент ;

ПроцессорВывода . УстановитьДокумент ( ДокументРезультат ) ;

ПроцессорВывода . Вывести ( ПроцессорКомпоновки ) ;

//ДокументРезультат.ПоказатьУровеньГруппировокСтрок(XXXXX); //Здесь указываем УРОВЕНЬ группировки

ДокументРезультат . ПоказатьУровеньГруппировокСтрок ( 0 ) ;

КонецПроцедуры

Одноклассники

Все материалы и продукты на этом сайте опубликованы для целей ознакомления для зарегистрированных пользователей фирм производителей материала или продукта, или его авторов. Помните, что скачанные материалы или продукты, Вы используете на свой страх и риск. Автор и администрация этого сайта не несет никакой ответственности за использование этих материалов или продуктов третьими лицами. В случае, если вы используете один из перечисленных здесь материалов или продуктов, Вы обязаны официально приобрести его у фирмы производителя или автора.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *